Mozilla crashes when launched if path contains directionality characters

RESOLVED DUPLICATE of bug 107181

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 107181
16 years ago
13 years ago

People

(Reporter: Gabi Danon, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020411

If the hard disk name contains an invisible directionality character, which is
included on many systems that use Hebrew, Mozilla will crash when launched.
Removing these characters solves the problem.

Reproducible: Always
Steps to Reproduce:
1.Rename the hard disk to something that contains the unicode chars
0x202c/202d/202e, which can be done with the Unicode Hex Input keyboard.
2.Try to launch Mozilla.


More information on these control characters in filenames can be found here:
http://homepage.mac.com/gabidanon/cleanbidi.html

*** This bug has been marked as a duplicate of 107181 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.