Closed Bug 12640 Opened 21 years ago Closed 21 years ago

[PP]M9 apprunner and viewer.app crash system when started

Categories

(Core :: Internationalization, defect, P3, blocker)

PowerPC
Mac System 8.6
defect

Tracking

()

CLOSED INVALID

People

(Reporter: warp-bugzilla, Assigned: ftang)

References

()

Details

(Whiteboard: [Perf])

Attachments

(1 file)

Both apprunner and viewer.app crash my German MacOS 8.6 system (192 MB Ram,
192 MB Virtual Memory, Version number shown in "about this computer": Mac OS
D1-8.6, Volume RAM Cache 6144KB, AppleTalk enabled, G3 300MHZ, QuickDraw Version
2.5.1)

viewer.app will start exactly one time, show its name in the menu bar,
create a file "Component Registry" (96880 Bytes), then hang until killed. A
second start results in an immediate system crash where viewer.app will not
even display its name in the menubar.

apprunner crashes the system immediately already when started for the first
time. Nothing is shown in the menubar, no files are created.

The M8 release showed the same behaviour, just forgot to report the bug.
No other programs where running while I ran the tests.

Please contact me if you need more information (like system extensions,
installed software etc.). Simply tell me what you'll n
Assignee: ssu → ftang
Component: Install Wizard → Internationalization
QA Contact: gbush → momoi
Target Milestone: M10
Sending over to Internationalization component.
Not sure why leger assign this to us.
Doesn't this sound like a corrupt pref problem, rather than an internationa problem?
For Mac OS8.6 Eng & JPN, I don't think we have this problem.
QA Contact: momoi → blee
Changing QA contact to blee.
I did some more testing:

I tried starting viewer/apprunner about 15 times. I discovered that sometimes I

can kill apprunner and it also creates the Component Registry file sometimes.

Also the size of the file varies - the largest one I got was 220KB.



I tried starting it with all possible system extensions disabled and without

virtual memory and it still crashes.



The longer I let one of both programs run, the worse it becomes. The computer

just seems to freeze. I usually still can kill them with alt command esc the

first 2-3 seconds. Afterwards trying to kill the program will effect nothing.

After about 10 seconds not even the mouse moves anym
this bug might be related to #12473
I wonder if the code to find special system directories in nsFileSpec is not
working on non-English systems?
Status: NEW → ASSIGNED
Target Milestone: M10 → M11
Change to M11 since mac is in untestable state these days. It may simply because
the Mac build is VERY VERY VERY slow these days.
Summary: M9 apprunner and viewer.app crash system when started → [PP]M9 apprunner and viewer.app crash system when started
Whiteboard: [Perf]
I could not reproduce this under German MacOS 8.6 with 1999-08-24-11-M9 ext bld.
Both apprunner and viewer.app launched fine, albeit sluggish, on a slowest
machine available, PowerMac7500/100 (32 MB RAM, 64MB VM).
This was a clean installation - no residual Mozilla pieces from previous
installation.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
Sorry, my fault. It does start - after 15 minutes of freezing my system ;-)
Status: RESOLVED → CLOSED
Closing as invalid
You need to log in before you can comment on or make changes to this bug.