If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

./mach reftest now spawns a booby-trapped blank Firefox window (which just gets in the way, and aborts your testrun if you accidentally click it)

RESOLVED DUPLICATE of bug 1255565

Status

Testing
Reftest
RESOLVED DUPLICATE of bug 1255565
2 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR:
 1. In a local debug build, run:
       ./mach reftest
    ...or:
       ./mach reftest layout/reftests/bugs/

 2. If any normal-looking Firefox windows appear (which you might confuse with a window from your normal Firefox browsing experience), try typing a URL into it -- say, mozilla.org -- and hit enter.

EXPECTED RESULTS:
 - Only two windows should appear: the reftest canvas, and possibly a little focus-stealing dummy window.


ACTUAL RESULTS:
 - In addition to those two windows, an *actual full Firefox browser-window* appears.
 - If you try to use it at all (e.g. if you're stupid enough to click in the URL bar or search bar), your testrun **will suddenly abort**  (!!), with this appearing in your terminal:
{
FATAL ERROR: Non-local network connections are disabled and a connection attempt to www.google.com (2607:f8b0:4005:801::2004) was made.
You should only access hostnames available via the test networking proxy
}

Hence: not only is this window unnecessary, it's "booby-trapped" (and is frustratingly a decoy which looks just like a normal Firefox window, inviting you to use it).


This extra window only started appearing recently (during reftest runs). I noticed a bunch of "Marionette" logging appearing around the same time -- I suspect (but am not sure) that it might be related to whatever's producing that logging.
(Reporter)

Updated

2 years ago
Summary: ./mach reftest now spawns a booby-trapped blank Firefox window (which just gets in the way, and aborts your testrun if you accidentally use it) → ./mach reftest now spawns a booby-trapped blank Firefox window (which just gets in the way, and aborts your testrun if you accidentally click it)
Requests to non-local remotes are disabled in CI to make tests hermetically reproducible.

I suspect the Marionette logging you see stems from installing the test-related add-ons at runtime, since unsigned add-ons can no longer be used with Firefox.  ahal, can you confirm this is the case here?
Flags: needinfo?(ahalberstadt)
(Reporter)

Comment 2

2 years ago
(In reply to Andreas Tolfsen ‹:ato› from comment #1)
> Requests to non-local remotes are disabled in CI to make tests hermetically
> reproducible

Yes, and this is a Good Thing.

The Bad Thing here is that we're now popping up this browser window, inviting/tempting me to click on it (which it responds to by immediately making a remote connection).

> I suspect the Marionette logging you see stems from installing the
> test-related add-ons at runtime, since unsigned add-ons can no longer be
> used with Firefox.  ahal, can you confirm this is the case here?

Hmm, ok. That sounds unrelated to the browser window that's popping up then -- so that logging might be a red herring.

Note: I'm currently using 'hg bisect' + rebuild + ./mach reftest to try to narrow down precisely when this window started appearing.

As an initial broad regression range, I believe 2016-02-16 was "good" (based on an old local build at revision 6ea654cad929 which I just tested), and 2016-03-31 was "bad" (based on an IRC discussion that I had that day about my local reftest run in an up-to-date build on that day).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(ahalberstadt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255565
You need to log in before you can comment on or make changes to this bug.