Facebook video in fullscreen has incorrect rendering

RESOLVED DUPLICATE of bug 1264142

Status

()

defect
RESOLVED DUPLICATE of bug 1264142
3 years ago
3 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

()

Attachments

(1 attachment)

Reporter

Description

3 years ago
Watching Facebook videos (4:3 aspect ratio) in fullscreen displays the old page background where black bars should be. This is on a Retina Macbook. Doesn't affect YouTube videos in fullscreen.
Reporter

Comment 1

3 years ago
Seems intermittent and I was able to repro without fullscreen on Facebook videos in the main timeline UI. The symptoms appear to be Gecko painting from a stale buffer for the background.
I can reproduce in Linux Nightly as well, using this video in fullscreen, in a fresh profile:
 https://www.facebook.com/mozilla/videos/10154006157677381/

In my normal browsing profile, I didn't hit this until the second time I entered fullscreen. So, this does seem to be a bit intermittent, but still not hard to trigger.
OS: Mac OS X → All
Hardware: x86_64 → All
I can reproduce with any fullscreen HTML5 video that doesn't fit my screen's aspect ratio.

For example, this screencast of a text editor.  Just load this video, and then click the fullscreen button on the video.

EXPECTED RESULTS: you should just see a text editor with black bars on the sides.
ACTUAL RESULTS: I see remnants of my Firefox window on the sides, instead of a black background.
Attachment #8740711 - Attachment description: testcase 1 → testcase 1 (view in fullscreen)
Dupe of bug 1264142 I think.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1264142
You need to log in before you can comment on or make changes to this bug.