crash in mozilla::ipc::SerializeInputStream

RESOLVED DUPLICATE of bug 1308916

Status

()

Core
DOM: Core & HTML
--
critical
RESOLVED DUPLICATE of bug 1308916
2 years ago
2 years ago

People

(Reporter: njn, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox47 affected, firefox48 affected, firefox49 affected)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-eec4b20b-eeca-4748-93e1-0ba782160412.
=============================================================

One occurrence of this on Nightly. Crashes on this line in /ipc/glue/InputStreamUtils.cpp:

>    MOZ_CRASH("Input stream is not serializable!");

Stack trace:

> 0 	XUL 	mozilla::ipc::SerializeInputStream(nsIInputStream*, mozilla::ipc::InputStreamParams&, nsTArray<mozilla::ipc::FileDescriptor>&) 	ipc/glue/InputStreamUtils.cpp
> 1 	XUL 	nsMultiplexInputStream::Serialize(mozilla::ipc::InputStreamParams&, nsTArray<mozilla::ipc::FileDescriptor>&) 	xpcom/io/nsMultiplexInputStream.cpp
> 2 	XUL 	mozilla::ipc::SerializeInputStream(nsIInputStream*, mozilla::ipc::InputStreamParams&, nsTArray<mozilla::ipc::FileDescriptor>&) 	ipc/glue/InputStreamUtils.cpp
> 3 	XUL 	mozilla::ipc::SerializeInputStream(nsIInputStream*, mozilla::ipc::OptionalInputStreamParams&, nsTArray<mozilla::ipc::FileDescriptor>&) 	ipc/glue/InputStreamUtils.cpp
> 4 	XUL 	mozilla::net::HttpChannelChild::ContinueAsyncOpen() 	netwerk/protocol/http/HttpChannelChild.cpp
> 5 	XUL 	mozilla::net::HttpChannelChild::AsyncOpen(nsIStreamListener*, nsISupports*) 	netwerk/protocol/http/HttpChannelChild.cpp
> 6 	XUL 	non-virtual thunk to mozilla::net::HttpChannelChild::AsyncOpen2(nsIStreamListener*) 	netwerk/protocol/http/HttpChannelChild.cpp
> 7 	XUL 	nsXMLHttpRequest::Send(nsIVariant*, mozilla::dom::Nullable<nsXMLHttpRequest::RequestBody> const&) 	dom/base/nsXMLHttpRequest.cpp
> 8 	XUL 	mozilla::dom::XMLHttpRequestBinding::send 	dom/base/nsXMLHttpRequest.h
> 9 	XUL 	mozilla::dom::GenericBindingMethod(JSContext*, unsigned int, JS::Value*) 	dom/bindings/BindingUtils.cpp
> 10 	XUL 	js::Invoke(JSContext*, JS::CallArgs const&, js::MaybeConstruct) 	js/src/jscntxtinlines.h

The user comment included "Recording WebM with getUserMedia".
(Reporter)

Comment 1

2 years ago
jesup, I'm not sure if you're the right person, but any suggestions are welcome :) Thank you.
Component: WebRTC: Networking → Audio/Video: Recording
Flags: needinfo?(rjesup)
Crashing inside of mozilla::net::HttpChannelChild::ContinueAsyncOpen() (while doing IPC things)
Component: Audio/Video: Recording → Networking: HTTP
Flags: needinfo?(rjesup) → needinfo?(mcmanus)

Comment 3

2 years ago
This is an xhr trying to upload a stream that is not serializable.  XHR could be changed to call nsIUploadChannel2::EnsureUploadStreamIsCloneable().  This would also ensure the stream is directly serializable.
Component: Networking: HTTP → DOM: Core & HTML
Flags: needinfo?(mcmanus)
For some reason to I can't load that minidump in Visual Studio.
Crash volume for signature 'mozilla::ipc::SerializeInputStream':
 - nightly(version 50):0 crashes from 2016-06-06.
 - aurora (version 49):29 crashes from 2016-06-07.
 - beta   (version 48):22 crashes from 2016-06-06.
 - release(version 47):1 crash from 2016-05-31.
 - esr    (version 45):0 crashes from 2016-04-07.

Crash volume on the last weeks:
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       0       0       0       0       0       0       0
 - aurora        0       7      17       5       0       0       0
 - beta          2       0       1       0       9       0       8
 - release       0       0       1       0       0       0       0
 - esr           0       0       0       0       0       0       0

Affected platform: Windows
status-firefox47: --- → affected
status-firefox49: --- → affected

Updated

2 years ago
See Also: → bug 1308916

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308916
You need to log in before you can comment on or make changes to this bug.