Closed Bug 1264236 Opened 4 years ago Closed 4 years ago

Implement the support for Directory in DataTransferEvent

Categories

(Core :: DOM: Core & HTML, defect)

47 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

(Whiteboard: btpp-active)

Attachments

(1 file, 1 obsolete file)

Attached patch dnd.patch (obsolete) — Splinter Review
No description provided.
Attachment #8740868 - Flags: review?(bugs)
Whiteboard: btpp-active
Comment on attachment 8740868 [details] [diff] [review]
dnd.patch

>-        bool isDir;
>-        aRv = file->IsDirectory(&isDir);
>+        bool isLink, isSpecial, isFile, isDir;
>+        if (NS_WARN_IF(NS_FAILED(file->IsSymlink(&isLink)) ||
>+                       NS_FAILED(file->IsSpecial(&isSpecial))) ||
>+            isLink || isSpecial) {
>+          continue;
>+        }
This breaks the current handling of links, right? Or explain why drag-and-dropping links keeps working?
(it works now in FF and in other browsers)

>+  // We are not going to use mFileList, but this object is created when
>+  // mFilesAndDirectories array is populated.
>+  if (!mFileList) {
>+    GetFiles(aRv);
>+    if (NS_WARN_IF(aRv.Failed())) {
>+      return nullptr;
>+    }
>+  }
So the comment isn't too clear. GetFiles actually ends up populating mFilesAndDirectories. Please explain that in the comment

r-, because I don't understand that link handling. Maybe I'm missing something, so if this doesn't break the current behavior, ask review again, but please
explain the link handling.
Attachment #8740868 - Flags: review?(bugs) → review-
Attachment #8740868 - Attachment is obsolete: true
Attachment #8768740 - Flags: review?(bugs)
Attachment #8768740 - Flags: review?(bugs) → review+
I'll add the support for directory in a separate patch. that requires quite big changes in e10s and so on.
https://hg.mozilla.org/mozilla-central/rev/ff117266d9de
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Duplicate of this bug: 1264374
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.