icewm.classic.themes.org: 'cols' attribute on table has wrong value

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
16 years ago
3 years ago

People

(Reporter: Christopher D. Jones, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.8) Gecko/20020205
BuildID:    2002020516

The following simplified html exhibits the behavior. The problem is when the
table is shown (under Mozilla) all of the columns are smushed up to the left of
the screen with the exception of the last column.  However if the cols="5" is
set to 6 in the table definition all works nicely.  I am comparing this against
Netscape Communicator 4.77, which seems to show the table properly.  The
http://www.icewm.classic.themes.org web page better show the problem since
actual images are used.

Reproducible: Always
Steps to Reproduce:
1.goto http://www.icewm.classic.themes.org
2.
3.

Actual Results:  The table is not shown properly therefore the graphics on the
we page are all smushed to the left.


    <table width="100%" border="2" cols="5"> 
	<tr>
	  <td>left</td>
	  <td>left center</td>
	  <td colspan=2>center</td>
	  <td>right center</td>
	  <td>right</td>
	</tr>
    </table>

Comment 1

16 years ago
Marking INVALID. You can't blame the browser for not knowing what to do when you
specify cols=5 but include 6 columns in the table. 'cols' isn't a valid
attribute for <table> anyway, so there is no correct and incorrect behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
I can understand the reasoning of course (garbage in, garbage out) but it seems
to me that the "cols isn't a valid attribute for table" reasoning might make
this be an even worse bug then, if an invalid or unknown attribute on a table
affects the way it's displayed.

Note however that an attribute of foo="5" doesn't affect the display of the
table but cols="5" does, which makes it seem to me like it's being treated as a
valid attribute on some level...

Is 'cols' a holdover from an early HTML spec (I took a quick look at 3.2, 4.0,
and the XHTML 1.0 Transitional DTD specs and didn't see it in any of those) that
has to be honored in some limited way or a proprietary extension added by
Netscape at some point or something like that?  If not, why is it affecting the
display?  If it was a proprietary extension, perhaps it should be removed now?

Comment 3

16 years ago
I'd love to see a Mozilla without any proprietary extensions, but unfortunately
it would be unable to render too many of the webpages out there. :-(

You can file a bug about removing support for the prop 'cols' attribute if you
like, but I can guarantee that it will be WONTFIXed. (I filed a bug recently
about removing support for <blink> (bug #124699), and even that was WONTFIXed...)

But that is not really relevant to this bug. Specifying cols=5 for a six column
table is asking for trouble. Look at it this way: Why spend time on fixing an
implementation of some proprietary extension when time could be spend on fixing
real standards-compliance bugs instead?

Marking VERIFIED INVALID.
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
The cols attribute is not part of html, but is supported by Nav4.6 and Mozilla 
in quirks mode. In this particular example, it sounds like Mozilla is rendering 
it differently than Nav4.6, but it is not an unreasonable rendering (make the 
1st 5 cols the same size and give the rest to the last col). Since there are a 
few pages that use cols, it will probably remain in quirks mode (hopefully it 
doesn't function in standard mode). But, no effort will be made to make it work 
like Nav4.x at this point.

Comment 5

16 years ago
We should get the site to fix this.
Status: VERIFIED → UNCONFIRMED
Component: HTMLTables → US General
OS: SunOS → All
Product: Browser → Tech Evangelism
Hardware: Sun → All
Resolution: INVALID → ---
Summary: table rendering error with columns specified → icewm.classic.themes.org: 'cols' attribute on table has wrong value
Version: other → unspecified

Comment 6

16 years ago
--> Tech Evangelism
Assignee: karnaze → doronr
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: amar → zach

Comment 7

15 years ago
URL redirects to freshmeat.net now, which displays fine. Marking INVALID because 
the site no longer exists.
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.