71.32% build times (windows8-64) regression on push 9943bdffe504 (Wed Apr 13 2016)

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
We see a change in build times for windows 8 related to push 9943bdffe504:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b49f022053304bd9cc3a902e414fe51efe26a06e&tochange=9943bdffe5045968571f18ba6a283cbb5df894e0

This is a list of all known regressions and improvements related to the push:
https://treeherder.mozilla.org/perf.html#/alerts?id=856

here is the graph:
https://treeherder.mozilla.org/perf.html#/graphs?series=%5Bmozilla-inbound,c71c6eaa478bb9048fe7f16658a86caf04e2b59a,1%5D&series=%5Bmozilla-inbound,668e1edbe52f9daa14ace77738b2d4bac168581f,1%5D

I don't know if this is a config issue or something unrelated to the patch (maybe a clobber from a slightly earlier changeset).  I thought I would file a bug to let folks know- this is windows only, doesn't show up on linux.

Updated

2 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
I was concerned about this earlier, because the regression appeared persistent (our new lower range for inbound builds appeared much higher), but looking at newer builds it seems less definitive: https://treeherder.mozilla.org/perf.html#/graphs?timerange=172800&series=%5Bmozilla-inbound,b24dd9c57bc94f92ce0cdbba599aef16a4c6d033,1%5D&series=%5Bmozilla-inbound,413ae1bdeebb951a00c3047744aa4b6eef0f21a0,1%5D
Note that my push has 3 very tiny patches (maybe 10 lines of code total).

I know, that doesn't have to say much, but it's not like the compiler suddenly has lots of extra code to compile.
Looking again at the graph in comment 1, we're pretty clearly back to the norm here. Inbound build times are inherently noisy, but if this had persisted it would have been an important to track down, so it's good we're detecting things like this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.