Closed Bug 12644 Opened 21 years ago Closed 21 years ago

[PP]ExtractCoreFile() stomps memory resulting in crash on shutdown

Categories

(SeaMonkey :: Installer, defect, P1, blocker)

PowerPC
Mac System 8.6
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: samir_bugzilla, Assigned: samir_bugzilla)

Details

It appears that calling DisposeWindow() on the Mac Install Wizard's only window
at Shutdown causes a crash. The state of the window appears to be valid: we have
gotten the window through the global pointer we store as well as through finding
the front window, verifying the refcon matches our kMIWMagic number and trying
to call DisposeWindow() on the window obtained from FrontWindow(). Both methods
appear to result in the same window being pointed to. However, calling
DisposeWindow() in either scenario results in a crash.
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: M10
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Was not releasing a StringPtr in the core file extraction routines. This appears
to have impacted the system and thus the crash. We are no longer crashing
and in fact shutting down gracefully.
Status: RESOLVED → REOPENED
Summary: DisposeWindow() causes crash → ExtractCoreFile() stomps memory resulting in crash on shutdown
Target Milestone: M10 → M11
The problem is that we seem to be stomping memory or the system when we extract
the core files. The problem has resurfaced. When we call Shutdown() any call to
the current window ptr (like HideWindow()/DisposeWindow()) causes a crash.
Resolution: FIXED → ---
Summary: ExtractCoreFile() stomps memory resulting in crash on shutdown → [PP]ExtractCoreFile() stomps memory resulting in crash on shutdown
Clearing Fixed resolution due to reopen.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Fixed. Build delivered to QA at http://dolfin/nsinstall/mac/nsinstall.sea.bin.
Status: RESOLVED → VERIFIED
sep13 MacInstallWizard (MIW)not crashing
Updating component from Install Wizard to Installer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.