Assertion failure: stream_ != stream, at media/mtransport/transportlayerice.cpp:106

RESOLVED DUPLICATE of bug 1264344

Status

()

Core
WebRTC: Networking
RESOLVED DUPLICATE of bug 1264344
2 years ago
2 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({assertion, crash})

Trunk
assertion, crash
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

(URL)

When loading a room on https://appear.in/ my debug build (current to yesterday) crashed the content process with:

Assertion failure: stream_ != stream, at /home/dbaron/builds/ssd/mozilla-central/mozilla/media/mtransport/transportlayerice.cpp:106
#01: mozilla::AddNewIceStreamForRestart_s(RefPtr<mozilla::PeerConnectionMedia>, RefPtr<mozilla::TransportFlow>, unsigned long, bool) (/home/dbaron/builds/ssd/mozilla-central/mozilla/media/webrtc/signaling/src/peerconnection/MediaPipelineFactory.cpp:213)
#02: RefPtr<mozilla::PeerConnectionMedia>::~RefPtr() (/home/dbaron/builds/ssd/mozilla-central/obj/firefox-debugopt/dist/include/mozilla/RefPtr.h:76)
#03: nsThread::ProcessNextEvent(bool, bool*) (/home/dbaron/builds/ssd/mozilla-central/mozilla/xpcom/threads/nsThread.cpp:994)
#04: NS_ProcessNextEvent(nsIThread*, bool) (/home/dbaron/builds/ssd/mozilla-central/mozilla/xpcom/glue/nsThreadUtils.cpp:297)
#05: nsSocketTransportService::Run() (/home/dbaron/builds/ssd/mozilla-central/mozilla/netwerk/base/nsSocketTransportService2.cpp:946)
#06: nsThread::ProcessNextEvent(bool, bool*) (/home/dbaron/builds/ssd/mozilla-central/mozilla/xpcom/threads/nsThread.cpp:994)
#07: NS_ProcessNextEvent(nsIThread*, bool) (/home/dbaron/builds/ssd/mozilla-central/mozilla/xpcom/glue/nsThreadUtils.cpp:297)
#08: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) (/home/dbaron/builds/ssd/mozilla-central/mozilla/ipc/glue/MessagePump.cpp:341)
#09: MessageLoop::RunInternal() (/home/dbaron/builds/ssd/mozilla-central/mozilla/ipc/chromium/src/base/message_loop.cc:231)
#10: MessageLoop::AutoRunState::~AutoRunState() (/home/dbaron/builds/ssd/mozilla-central/mozilla/ipc/chromium/src/base/message_loop.cc:505)
#11: nsThread::ThreadFunc(void*) (/home/dbaron/builds/ssd/mozilla-central/mozilla/xpcom/threads/nsThread.cpp:398)
#12: _pt_root (/home/dbaron/builds/ssd/mozilla-central/mozilla/nsprpub/pr/src/pthreads/ptthread.c:219)
#13: start_thread (/build/glibc-ryFjv0/glibc-2.21/nptl/pthread_create.c:333)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1264344
You need to log in before you can comment on or make changes to this bug.