Investigate crossOrigin related test failures in testing/web-platform/tests/html/semantics/embedded-content/the-img-element/relevant-mutations.html

RESOLVED FIXED in Firefox 49

Status

()

Core
DOM
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

Trunk
mozilla49
Points:
---

Firefox Tracking Flags

(firefox48 affected, firefox49 fixed)

Details

(Whiteboard: [tw-dom] btpp-active)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Steps to reproduce:
Open http://w3c-test.org/html/semantics/embedded-content/the-img-element/relevant-mutations.html

Actual results:
Test failed in 
* crossorigin state not changed: empty to anonymous, assert_unreached: update the image data was run Reached unreachable code
* crossorigin state not changed: anonymous to foobar, assert_unreached: update the image data was run Reached unreachable code
* crossorigin state not changed: use-credentials to USE-CREDENTIALS, assert_unreached: update the image data was run Reached unreachable code

Expected results:
Ideally, 100% of these tests would pass.
(Assignee)

Comment 1

2 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #0)
> Test failed in 
> * crossorigin state not changed: empty to anonymous, assert_unreached:
> update the image data was run Reached unreachable code
> * crossorigin state not changed: anonymous to foobar, assert_unreached:
> update the image data was run Reached unreachable code
> * crossorigin state not changed: use-credentials to USE-CREDENTIALS,
> assert_unreached: update the image data was run Reached unreachable code

The relevant mutations for an img element includes "The element's crossorigin attribute's state is changed". But in above three cases, the crossorigin's state isn't changed.

See:
https://html.spec.whatwg.org/multipage/embedded-content.html#relevant-mutations
https://html.spec.whatwg.org/multipage/embedded-content.html#attr-img-crossorigin
https://html.spec.whatwg.org/multipage/infrastructure.html#cors-settings-attribute
(Assignee)

Comment 2

2 years ago
Created attachment 8741185 [details] [diff] [review]
Patch, v1

Updated

2 years ago
Whiteboard: [tw-dom] → [tw-dom] btpp-active
Summary: Investigate corssOrigin related test failures in testing/web-platform/tests/html/semantics/embedded-content/the-img-element/relevant-mutations.html → Investigate crossOrigin related test failures in testing/web-platform/tests/html/semantics/embedded-content/the-img-element/relevant-mutations.html
(Assignee)

Comment 3

2 years ago
Created attachment 8748994 [details] [diff] [review]
Patch, v2
Attachment #8741185 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Blocks: 1087614
(Assignee)

Comment 5

2 years ago
Comment on attachment 8748994 [details] [diff] [review]
Patch, v2

Review of attachment 8748994 [details] [diff] [review]:
-----------------------------------------------------------------

Force a reload only when the cross origin policy is changed, and do reload after attribute has been set in order to use new cross origin policy correctly.
Attachment #8748994 - Flags: review?(josh)

Comment 6

2 years ago
Comment on attachment 8748994 [details] [diff] [review]
Patch, v2

Review of attachment 8748994 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #8748994 - Flags: review?(josh) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/93bc222914a2
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1087614
You need to log in before you can comment on or make changes to this bug.