crash in mozilla::a11y::IDRefsIterator::IDRefsIterator

RESOLVED FIXED in Firefox 48

Status

()

defect
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: njn, Assigned: surkov)

Tracking

({crash})

Trunk
mozilla48
x86
Windows NT
Points:
---

Firefox Tracking Flags

(firefox48 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-bb3b4f86-9f18-4b1a-97e9-8eec82160413.
=============================================================

A new crash in Nightly 20160413030239. Occurred 43 time on 26 installations. The crash address is 0x18 or 0x30 in all the occurrences. Presumably related to all the other a11y crashes we've seen lately.
(Reporter)

Comment 1

3 years ago
surkov, can you please investigate?
Flags: needinfo?(surkov.alexander)
(Assignee)

Comment 2

3 years ago
Posted patch patchSplinter Review
Flags: needinfo?(surkov.alexander)
Attachment #8741355 - Flags: review?(yzenevich)
Thanks for jumping on this.
Aside: perhaps obviously, regression range looks like http://mzl.la/1Natg2M (Bug 1263188 or Bug 1262415?)
Assignee: nobody → surkov.alexander
Comment on attachment 8741355 [details] [diff] [review]
patch

Review of attachment 8741355 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, would we want to check some unexpected events in test?
Attachment #8741355 - Flags: review?(yzenevich) → review+
(Assignee)

Comment 5

3 years ago
(In reply to Yura Zenevich [:yzen] from comment #4)

> Looks good, would we want to check some unexpected events in test?

the test is for the crash primarily, eventing is much covered by events/test_coalescence.html
(Assignee)

Comment 6

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/73f507eb28770e6e99e72546dab27f0959cfa3c5
Bug 1264526 - process ARIA owns relocations for in-the-document accessibles only, r=yzen

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/73f507eb2877
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.