Closed Bug 12646 Opened 21 years ago Closed 20 years ago

[WEBSHELL] When loading page with textareas, they draw at top of page

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: buster)

References

()

Details

(Whiteboard: will verify in 12/2 build.)

Build ID: 1999082616 (GFX widgets enabled)
Platform: Windows NT (presumably on Mac, Linux as well)

To reproduce:
- Launch apprunner
- Load the above URL

Result: All of the text input fields, text areas, etc. and the content in them
is drawn at the top of the browser window (underneath the button bar)
repeatedly, each one replacing the previous one, until the page finishes
loading, at which point it is refreshed and looks OK.

Expected result: You shouldn't be seeing all of that drawing.
Assignee: trudelle → buster
Component: XP Toolkit/Widgets → Editor
This is not an XPToolkit widget, please start reporting such problems against
the Editor component.

reassigning to buster, cc kmcclusk, changing component to Editor
Status: NEW → ASSIGNED
Depends on: 13374
Target Milestone: M12
this is an oddity due to insufficient support in the webshell to do the right
thing.  Hopefully we can clean this up in M12.
*** Bug 13958 has been marked as a duplicate of this bug. ***
QA Contact: phillip → sujay
Whiteboard: [WEBSHELL]
adding a tracking phrase for me in S.W.
Summary: When loading page with textareas, they draw at top of page → [WEBSHELL] When loading page with textareas, they draw at top of page
Whiteboard: [WEBSHELL]
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed.  the webshell/view stuff used by text controls was partially fixed a few
weeks ago, so the painting oddities have gone away.
Whiteboard: will verify in 12/2 build.
Status: RESOLVED → VERIFIED
verified in 12/2 build.
You need to log in before you can comment on or make changes to this bug.