Closed Bug 12647 Opened 21 years ago Closed 21 years ago

When form displayed, text in textareas, inputs etc highlighted

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: buster)

References

()

Details

Build ID: 1999082616 (GFX widgets enabled)
Platform: Windows NT (assuming Mac OS and Linux are similar)

To reproduce:
- Launch apprunner and make sure GFX widgets are enabled
- Load the above URL (Netscape internal only) or any page that contains a form
with text already entered in some of the text input controls, textareas, etc.

Result: The text that already exists in the text input controls ("No visual
indication" etc. in the test case) is highlighted.

Expected result: it shouldn't be.
Validated behavior in Apprunner. Also tested using Viewer (Win 95) - text is
not highlighted
Assignee: trudelle → buster
Component: XP Toolkit/Widgets → Editor
This is Ender, not an XPTooolkit widget. reassigning to buster, cc kmcclusk
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I believe this is already fixed.  Checked in 08/24/1999 06:52,
mozilla/layout/html/forms/src/nsGFXTexControlFrame.cpp version 3.34
Looks like this was indeed fixed. Verified using the Windows NT 1999083010
build; phillip, if this works for you on linux, please close (or yell over the
cubicle partitions, and I'll check it and close it). Thanks!
Status: RESOLVED → VERIFIED
verified on redhat 6.0 with gfx widgets turned on and off, build 1999-08-30-02
You need to log in before you can comment on or make changes to this bug.