Closed Bug 1264704 Opened 5 years ago Closed 2 months ago

URL Bar loses its focus in about:home during search process

Categories

(Firefox :: Address Bar, defect, P4)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected
firefox48 --- affected
firefox69 --- affected
firefox70 --- affected
firefox71 --- affected

People

(Reporter: JuliaC, Unassigned)

Details

(Whiteboard: [fxsearch], [qe-search])

Attachments

(1 file)

[Affected versions]:
- 48.0a1 (2016-04-14)
- 47.0a2 (2016-04-14)
- 46.0b10 build1 (20160411042519)
- 45.0.2 build1 (20160407164938)

[Affected platforms]:
- Windows 10 x64
- Windows 7 x64
- Ubuntu 14.04 x86
- Mac OS X 10.10.5

[Steps to reproduce]:
1. Launch Firefox.
2. Go to about:home
3. Click the URL bar in order to focus it, type a random word and then hit Enter. 
4. Inspect the search bar.

[Expected result]:
- The URL bar remains in focus until the search results are loaded.

[Actual result]:
- After step 3, the focus passes from URL bar to search bar while the search results are loading.

[Regression range]:
- This issue also reproduces on old Firefox builds, including 30.0 and 4.0, so I do not believe that it is a regression.
By search bar you mean the in-content input field, not the search bar in the toolbar, right? At least that's what I've observed in my testing gets the focus.
Priority: -- → P4
Whiteboard: [fxsearch]
(In reply to Panos Astithas [:past] from comment #1)
> By search bar you mean the in-content input field, not the search bar in the
> toolbar, right? At least that's what I've observed in my testing gets the
> focus.

Yes, indeed, I mean the in-content input field, not the search bar in the toolbar. I`ve also created an screen recording of the issue, in order be more specific. Thanks!
Whiteboard: [fxsearch] → [fxsearch], [qe-search]

¡Hola!

Updating flags as I can still reproduce this on Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0 ID:20190911095413

¡Gracias!
Alex

I believe this is a "works for me". When visiting a page, the focus is changed to the page itself, as that is what the user would expect.

In this case, this was the old home page that took the focus on the search bar. Now the focus just ends up on the page.

Status: NEW → RESOLVED
Closed: 2 months ago
Component: Search → Address Bar
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.