Problem importing mail from Outlook

VERIFIED FIXED in mozilla1.0

Status

MailNews Core
Backend
P1
major
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Tommy Amstrad, Assigned: Cavin Song)

Tracking

Trunk
mozilla1.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

669 bytes, patch
Jean-Francois Ducarroz
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020219
BuildID:    2002021903

The fixes performed in Bug 125131 have not fixed the following problem.

My Outlook 2000 mailbox is as below:

   --Deleted Items (55 items)

   --Drafts (16 items)
     |--isp (7 items)

   --Inbox (126 items)
     |--Jobs (134 items)
     |--Overclockers (82 items)
     |--Shopping (83 items)

   --Outbox (0 items)

   --Sent Items (1402 items)

After importing into Mozilla using the import option, I get the following summary:

  Mailbox Jobs, imported 134 messages
  Mailbox Shopping, imported 83 messages
  Mailbox Overclockers, imported 82 messages
  Mailbox Outbox, imported 0 messages
  Mailbox Sent Items, imported 1402 messages
  Mailbox Drafts, imported 16 messages
  Mailbox isp, imported 7 messages

Now that bug 125131 is fixed the numbers of messages in each folder are
correctly reports, but the 'Inbox' and 'Deleted Items' are missing from this
summary.

After the import, in Mozilla I have the following folder structure:

--Inbox (118)
  |--Jobs (129)
  |--Overclockers (82)
  |--Shopping (81)
--Outbox
--Unsent Messages
--Drafts
--Templates
--Sent
--Trash
--Deleted Items (1)
--Drafts0 (16)
  |--isp (7)
--Sent Items (1402)

The Inbox has 119 (118 unread, 1 read) messages in it and so is missing  7
messages. Deleted Items has one message in and so is missing 54 messages. All
other folders are correctly imported.

All dates, subjects and 'from addresses' appear to have imported correctly.



Reproducible: Always
Steps to Reproduce:
1.Create new profile
2.Select Import Outlook
(Reporter)

Comment 1

16 years ago
Backed up my outlook.pst and deleted all the messages and extra folders. I just 
left 4 messages in my Inbox including the message that I described in Bug 
125131 that I suspect is causing the problem.

The import summary gave the following:

  Mailbox Deleted Items, imported 0 messages
  Mailbox Outbox, imported 0 messages
  Mailbox Sent Items, imported 0 messages
  Mailbox Drafts, imported 0 messages

The folder structure in Mozilla is:

  --Inbox (2)
  --Outbox
  --Unsent Messages
  --Drafts
  --Templates
  --Sent
  --Trash
  --Deleted Items
  --Drafts0
  --Sent Items

All folders are empty other than Inbox which has just two unread messages in it.

The two missing messages are the 'suspected problem email' and the latest email 
in the inbox.
Summary: Problem importing mail from Outlook → Problem importing mail from Outlook
(Reporter)

Comment 2

16 years ago
With only the four messages in my Inbox, if I delete the 'suspect email' before 
importing then the 3 remaining messages get imported with out problem.
(Reporter)

Comment 3

16 years ago
With only the suspect email in my Inbox and all other folders empty, I get no 
messages appearing in Mozilla. If I look at the actual mail files in my Mozilla 
profile then all files are empty except Inbox which only contains the following 
text:

   From - Tue, 19 Feb 2002 22:14:56

Therefore there are still two issues with the Outlook import.

1. Why is this files causing problems
2. Import errors are not being displayed
-> cavin@netscape.com
Assignee: mscott → cavin
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
QA Contact: esther → nbaca
(Assignee)

Comment 5

16 years ago
Reporter, thanks for testing out the fix to bug 125131. Looks like we are making
progress.  For the new problem, is it possible for you to send me (ie, email me
directly) your test outlook.pst so that I can reproduce it here? You can just
have the problem msg in the inbox (ie, 1 msg). I'm curious to see why this msg
is causing the problem for you. I actually used Unix sendmail to send the
problem msg you pasted to bug 125131 and received it in Outlook but I did not
see the import problem you described.
Priority: -- → P1
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 6

16 years ago
Sadly the problem email is from my credit card company and I would prefer not 
to send out the outlook.pst file. I am sorry I know this doesn't give you much 
to gone on.
(Assignee)

Comment 7

16 years ago
No problem. So before I can figure out what the problem is you can move this bad
msg out to a separate folder (so that it does not stop other msgs from being
imported) and then import all your msgs. Then you can manually forward this msgs
to yourself and receive it in Mozilla.  Only a workaround but at least will get
you going.  I'm assuming that all other problems in bug 125131 have been fixed
here. Please add a comment to 125131 if you think this it true.

Updated

16 years ago
Keywords: nsbeta1+
(Assignee)

Comment 8

16 years ago
Since I could not reproduce the problem so I'm guessing that this maybe caused 
by "msg size" issue.  Reporter, is it possible that you export this msg out to a 
file and remove the sensitive info in the body by replacing all chars with '-'. 
In other words, don't delete characters from body, rather, replace them with '-' 
for example.  Do the same thing for headers but you do need to keep the standard 
headers like "From:", "To:", etc.  Try your best to keep the msg size intact. 
Then email me the edited msg file if it's possible for you to do this. Thanks.
(Reporter)

Comment 9

16 years ago
Sorry for the delay.

I exported the message from outlook to a file (.msg file) but if I edit any of 
the file then it cannot be reimported back into outlook.

I also copied my outlook.pst file and deleted every message except the problem 
one. I then open the problem message in Outlook and removed entire body of the 
text.

I the tried importing into Mozilla (0.9.9 2002031104) and the problem still 
occurred. So it looks like something in the headers is the problem.
(Reporter)

Comment 10

16 years ago
Cavin, I have emailed you the outlook.pst file that contains just the problem 
email, with the main text deleted.
(Assignee)

Comment 11

16 years ago
Thanks and I'll take a look at it.
(Assignee)

Comment 12

16 years ago
OK, found the problem and is caused by that the very first header does not have 
a value associated with it (ie, X-SomeHeader: ) AND it is not a header we really 
care about.  In this case the code would skip all message headers.  
Initializing an nsresult variable to NS_OK fixes the problem.
(Assignee)

Comment 13

16 years ago
Created attachment 74807 [details] [diff] [review]
Proposed patch, v1

Init 'rv' to NS_OK so that we don't stop on the first header which does not
have a value associated with it.

Comment 14

16 years ago
Comment on attachment 74807 [details] [diff] [review]
Proposed patch, v1

sr=bienvenu
Attachment #74807 - Flags: superreview+
Comment on attachment 74807 [details] [diff] [review]
Proposed patch, v1

R=ducarroz
Attachment #74807 - Flags: review+

Comment 16

16 years ago
Comment on attachment 74807 [details] [diff] [review]
Proposed patch, v1

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #74807 - Flags: approval+
(Assignee)

Comment 17

16 years ago
Fix checked in on trunk.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

16 years ago
Reporter, can you try the latest build to see if it fixes your problem? Thanks.
(Reporter)

Comment 19

16 years ago
Imported my Outlook mailbox with Mozilla build 2002031903 and it has imported 
the problem message.

Comment 20

16 years ago
Verified Fixed, per reporter's comments and general use.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.