Closed Bug 1264858 Opened 3 years ago Closed 3 years ago

Azure hardware acceleration fails on certain hardware

Categories

(Core :: Graphics, defect)

45 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1248183

People

(Reporter: craig.leat, Unassigned)

Details

(Keywords: html5, Whiteboard: [gfx-noted])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160325004906

Steps to reproduce:

Using Firefox on Android try the following demo:
http://www.mazeware.com/test.html

On certain devices the <canvas> element will not update with Azure hardware acceleration enabled. More details here: https://support.mozilla.org/en-US/questions/1109701


Actual results:

On a Samsung SM-T231 (7" Android 4.4.2 tablet) the canvas freezes and will not update. Refreshing the browser does not help. Another device with different hardware, but same Android and Firefox works correctly.

The demo works with gfx.canvas.azure.accelerated = false.


Expected results:

My html5 games must work with default Firefox settings. I cannot expect users to tinker inside about:config.
Keywords: html5
OS: Unspecified → Android
Hardware: Unspecified → ARM
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248183
You need to log in before you can comment on or make changes to this bug.