Closed Bug 1264898 Opened 4 years ago Closed 4 years ago

Remove unnecessary |FinishAddTracks| call in |DOMHwMediaStream::Init|

Categories

(Core :: Audio/Video: MediaStreamGraph, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: ctai, Assigned: ctai)

Details

Attachments

(1 file)

Confirmed with dmu, the call of |FinishAddTracks| call in |DOMHwMediaStream::Init|. Because the track added is not a ADDTRACK_QUEUED.
Attached patch Bug1264898.diffSplinter Review
Attachment #8741705 - Flags: review?(pehrsons)
Attachment #8741705 - Flags: review?(rjesup)
Attachment #8741705 - Flags: review?(pehrsons) → review+
Attachment #8741705 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/mozilla-central/rev/15a13875356f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.