Single-stepping code in Firefox for Android via WebIDE doesn't work

RESOLVED DUPLICATE of bug 1263629

Status

()

Firefox
Developer Tools: Debugger
P1
major
RESOLVED DUPLICATE of bug 1263629
2 years ago
2 years ago

People

(Reporter: JanH, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fixed)

Details

(Reporter)

Description

2 years ago
Testing with the 2016-04-14 Nightly on both desktop and mobile, trying to debug some JS code in Firefox for Android doesn't really seem to work:

STR:
- Connect to Firefox for Android, start debugging the main process and set a breakpoint somewhere, e.g. at the top of AddTab() in browser.js or somewhere in handleEvent() in sessionstore.js, e.g. on the call to this.onTabAdd().
- Trigger the breakpoint (by opening a new tab if you followed the above suggestions).
- Try single-stepping.

Expected:
The debugger runs a single step as instructed.

Actual:
One or more out of:
- Instead of single-stepping as expected, I suddenly end up in promise-backend.js (https://dxr.mozilla.org/mozilla-central/rev/21bf1af375c1fa8565ae3bb2e89bd1a0809363d4/toolkit/modules/Promise-backend.js#974)
- Sometimes the debugger gets stuck, i.e. pressing any of the single-step/run/pause buttons doesn't have any effect any more.
- The console fills with messages about
11:33:27.398 DebuggeeWouldRun: debuggee `resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:500' would run1TabSources.js:404:14 and
11:33:35.010 DebuggeeWouldRun: debuggee `resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:500' would run1TabSources.js:358:14
Thanks for the report!

This should get fixed soon by the work in bug 1263629.  It has already landed to fx-team, so we just need to wait for it to merge to mozilla-central too.  You would then need to use a build of Firefox for Android that contains the changes.
Blocks: 1240804
Depends on: 1263629
Keywords: regression
Priority: -- → P1
(Reporter)

Comment 2

2 years ago
I've rebuilt Firefox from mozilla-central after bug 1263629 has landed and debugging works again. Thanks very much.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1263629
status-firefox48: affected → fixed
You need to log in before you can comment on or make changes to this bug.