Closed Bug 1264931 Opened 4 years ago Closed 4 years ago

Weave.js NS_ERROR_NOT_AVAILABLE for resource://services-sync/util.js spamming logs on infra and locally on every browser startup

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 48
Tracking Status
firefox48 --- fixed

People

(Reporter: Gijs, Assigned: myk)

References

Details

Attachments

(1 file)

e.g.

http://archive.mozilla.org/pub/firefox/try-builds/gijskruitbosch@gmail.com-3b48193ca6f07370db7cce8d89cbccc1a96f15ea/try-win32/try_win7-all_test-mochitest-e10s-4-bm127-tests1-windows-build778.txt.gz


20:57:42     INFO -  JavaScript error: jar:file:///C:/slave/test/build/application/firefox/omni.ja!/components/Weave.js, line 13: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXPCComponents_Utils.import]

find bar finds 96 matches in that log file alone. I see this on my local machine as well.

This is annoying. Please make it stop.
Seems it wants to import resource://services-sync/util.js which presumably doesn't exist.
Summary: Weave.js NS_ERROR_NOT_AVAILABLE spamming logs on infra and locally on every browser startup → Weave.js NS_ERROR_NOT_AVAILABLE for resource://services-sync/util.js spamming logs on infra and locally on every browser startup
(In reply to :Gijs Kruitbosch from comment #1)
> Seems it wants to import resource://services-sync/util.js which presumably
> doesn't exist.

It does seem to exist on my nightly... from a debug log (cf. https://public-artifacts.taskcluster.net/H8pjqFktTOasKZE-LYsfhA/0/public/logs/live_backing.log ) it seems like this might be because it's getting invoked at startup and that file doesn't exist yet. Looking for blame on the manifest entry in question, looks like this was bug 1250352. Also:

11:39:47     INFO -  [Child 1250] WARNING: Cannot create startup observer : service,@mozilla.org/weave/service;1: file /home/worker/workspace/build/src/embedding/components/appstartup/nsAppStartupNotifier.cpp, line 81

doesn't sound very good... (cf. https://public-artifacts.taskcluster.net/H8pjqFktTOasKZE-LYsfhA/0/public/logs/live_backing.log )
Blocks: 1250352
Flags: needinfo?(myk)
Flags: needinfo?(gps)
Ah, I was wondering if the change in bug 1250352 would rear its ugly head.  The change in question removes some code that was added for WebappRT, which I removed from the tree.  But I suspected that code had gained some hidden dependencies, even though I couldn't identify them, and now I know that it's (at least) xpcshell.

So here's a patch that reverts the change, updating the comment to reflect the new reason why we have to restrict WeaveService's app-startup category registration to a specific list of apps.

I tried to try (a build like the one referenced in comment 0, although this should reproduce on other builds), but try itself fails:

> ./mach try -b do -p win32 -u mochitest-e10s-4 -t none
mach try is under development, please file bugs blocking 1149670.
[bug-1264931-revert-app-startup-category-weave 9c12b36] try: -b do -p win32 -u mochitest-e10s-4 -t none
Bundling 2 changesets
Bundling 1 manifests
Bundling 1 files
remote: replication log not available; all writes disabled
remote: abort: pretxnopen.vcsreplicator hook failed
To hg::ssh://hg.mozilla.org/try
 ! [remote rejected] HEAD -> branches/default/tip (nothing changed on remote)
error: failed to push some refs to 'hg::ssh://hg.mozilla.org/try'
ERROR git command ['git', 'push', 'hg::ssh://hg.mozilla.org/try', '+HEAD:refs/heads/branches/default/tip'] returned 1

Yoda would disapprove.
Assignee: nobody → myk
Status: NEW → ASSIGNED
Flags: needinfo?(myk)
Attachment #8741884 - Flags: review?(gps)
Attachment #8741884 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/399b39bb0377
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
You need to log in before you can comment on or make changes to this bug.