Closed Bug 126505 Opened 18 years ago Closed 16 years ago

microsoft.com - "undefined" instead of page header, only accepts Windows MSIE

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jw_12, Unassigned)

References

()

Details

(Whiteboard: [proprietary-js])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Mozilla renders the page without the header and menu. Instead it
shows the text "undefined".

NAV 4.76 has the same problem. IE4 shows fine.

Reproducible: Always
Steps to Reproduce:
1.Load the page
2.Observe the "undefined"


Actual Results:  Does not show the page header + Menu

Expected Results:  Showing the page in full.
Looks like bad/non-existent browser sniffing at
<URL:http://www.microsoft.com/library/toolbar/toolbar.js>.  Over to Evang.
Assignee: attinasi → doronr
Status: UNCONFIRMED → NEW
Component: Layout → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: other → unspecified
Blocks: MS
Keywords: evang500
Summary: Getting "undefined" text instead of page header → microsoft.com - Getting "undefined" text instead of page header
Spoofing the userAgent causes the header to display, with document.all and MS
DOM errors.

Error: idMSMenuPane is not defined
Source File: http://www.microsoft.com/library/toolbar/toolbar.js
Line: 290

Error: ToolbarBGColor has no properties
Source File: http://www.microsoft.com/library/toolbar/toolbar.js
Line: 239
OS: Windows NT → All
Hardware: PC → All
Summary: microsoft.com - Getting "undefined" text instead of page header → microsoft.com - "undefined" instead of page header, only accepts Windows MSIE
Whiteboard: [proprietary-js]
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us
page is a 404 now
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.