pages with macromedia flash / shockwave crash mozilla 0.98 (flash plugin v 5,0,47,0) - M099 [@ libc.so.6]

VERIFIED DUPLICATE of bug 58937

Status

--
critical
VERIFIED DUPLICATE of bug 58937
17 years ago
3 years ago

People

(Reporter: mozjoy5.10.joek, Unassigned)

Tracking

({crash, qawanted, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

I am using the same flash plugin that used to work on mozilla 0.97.  Now
mozilla 0.98 crashes when it loads pages like http://www.locatel.fr/ that use 
flash.




Reproducible: Always
Steps to Reproduce:
1.Visit http://www.locatel.fr/
2.
3.

Actual Results:  The page starts to load in the browser window, which then
freezes.  All mozilla windows likewise freeze... they no longer display what they 
should but start to show "reflections" of other windows that are moved
over them.  Mozilla needs to be killed and restarted.

Expected Results:  The page should load and show the flash using the plugin. 
The browser should not crash.

flash plugin v 5,0,47,0

Linux distribution: RedHat 7.1

Comment 1

17 years ago
could u pls use a recent ...very recent build and pls retry? there have been 
quite a few bugs on flash crashers recently..some got fixed..maybe. Or this 
might be even a dup...if you could provide a stack trace.

Comment 2

17 years ago
Judging by the description this isn't a crash but a hang/freeze.
Reporter: Are you using /dev/dsp while this happens?
(Playing sound.. xmms or other)
Suspecting duplicate of bug 58339.

Comment 3

17 years ago
Mozilla 0.9.9
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Mozilla 0.9.9 crashes when going to http://www.locatel.fr/ (no window freeze). 
There is similar behavior with ShockWave rich http://www.oligo.com

Looks serious to me. 

Comment 4

17 years ago
still no crash for me ; redhat 7.1; 0311 trunk. I tried with/without the plugin. 
...no crash

Comment 5

17 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
WFM http://www.locatel.fr  rh 7.2 mozilla 0.9.9+ debug
darked@burnham.org could you provide any talkback incident ID fro for the 
crashes, please? 
Assignee: av → serge

Comment 7

17 years ago
Can any of the folks who have been able to reproduce this provide a talk back 
report or a trace of any kind that we can look at?

Comment 8

17 years ago
reporter, are u seeing bug 58339 ? seeing this hang while playing music?  pls 
comment.

Comment 9

17 years ago
Crashes occur only with flash plugin. Computer is silent while mozilla crashes 
but I do not have gnome-audio installed. 
I've send bziped talkback to serge@netscape.com 

Comment 10

17 years ago
darked, thank you I got it, but it would be more useful if you send talkback 
incident info to the talkback services, and post ID here.
TB services will properly match the submitted data with symbols info for any TB 
enabled build of mozilla, and presents the stack trace in human readable format.

Comment 11

17 years ago
Here is darked's incident:

 Incident ID 4229173   
Stack Signature  libc.so.6 + 0x80b7c (0x40540b7c) 4c699d16
Trigger Time 2002-03-19 13:19:37
Email Address darked@burnham.org
URL visited www.locatel.fr
Build ID 2002031312
Product ID MozillaBranch
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
User Comments Accessing the above page. Mozilla installed in my home directory
with a freshly downloaded flash plugin: -rw-r--r-- 1 darked darked 947992 Mar 19
13:35 libflashplayer.so -rw-r--r-- 1 darked darked 2363 Mar 19 13:35
ShockwaveFlash.class Bugzilla Bug 126510
Stack Trace
libc.so.6 + 0x80b7c (0x40540b7c) 

This also appears to be a topcrasher according to Talkback for Mozilla 0.9.9. 
Here is a set of crashes from that milestone:
Count   Offset    Real Signature
[ 4   libc.so.6 + 0x80b9c (0x40571b9c) 17515859 - libc.so.6 + 0x80b9c (0x40571b9c) ]
[ 2   libc.so.6 + 0x80f7c (0x40565f7c) d1ebd305 - libc.so.6 + 0x80f7c (0x40565f7c) ]
[ 2   libc.so.6 + 0x80b7c (0x40540b7c) 4c699d16 - libc.so.6 + 0x80b7c (0x40540b7c) ]
[ 2   libc.so.6 + 0x7fce0 (0x40546ce0) f8cd2fe9 - libc.so.6 + 0x7fce0 (0x40546ce0) ]
[ 2   libc.so.6 + 0x7493f (0x4053c93f) a81579b7 - libc.so.6 + 0x7493f (0x4053c93f) ]
 
     Crash date range: 2002-03-16 to 2002-03-19
     Min/Max Seconds since last crash: 21 - 65408
     Min/Max Runtime: 38 - 113807
     Keyword List :  
     Count   Platform List 
     4   Linux 2.4.8-26mdk   
     2   Linux 2.4.9-31   
     2   Linux 2.4.16   
     2   Linux 2.4.10-4GB   
     1   Linux 2.4.7-10smp   
     1   Linux 2.4.7-10   
 
     Count   Build Id List 
     8   2002031008
     4   2002031312
 
     No of Unique Users         7
 
 Stack trace(Frame) 

	 libc.so.6 + 0x80b9c (0x40571b9c)   
 
     (4229173)	URL: www.locatel.fr
     (4229173)	Comments: Accessing the above page.  Mozilla installed in my home directory
with a freshly downloaded flash plugin:-rw-r--r--    1 darked   darked    
947992 Mar 19 13:35 libflashplayer.so-rw-r--r--    1 darked   darked       2363
Mar 19 13:35
     (4229173)	Comments:  ShockwaveFlash.classBugzilla Bug 126510
     (4186401)	URL: www.sms.de
     (4186401)	Comments: another window rised with a popup within a remote X-session
     (4147285)	Comments: Trying to connect to:motogp.com
     (4139911)	URL: www.nvidia.com
     (4139911)	Comments: Flash pages makes the browser crash when used on a X-window client
     (4105608)	URL: http://www.macromedia.com

For some reason we don't get a stack trace for these crashes, but from looking
at the comments...this is definitely a problem with flash.  

Adding qawanted to see if we can get this reproduced internally.  If anyone is
able to reproduce this again, we should nominate it for nsbeta1.
Keywords: crash, qawanted, topcrash
Summary: pages with macromedia flash / shockwave crash mozilla 0.98 (flash plugin v 5,0,47,0) → pages with macromedia flash / shockwave crash mozilla 0.98 (flash plugin v 5,0,47,0) - M099 [@ libc.so.6]

Comment 12

17 years ago
according to some users comments they were crashing on remote X display:(
that is known flash issues bug #58937.

Comment 13

17 years ago
This could be duped to bug #58937?

Comment 14

17 years ago

*** This bug has been marked as a duplicate of 58937 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
Reporter, I assume you were using a remote X display and that's the reason u 
were crashing. Hence, marking this verif. If this is not the case, pls reopen if 
u see this on a recent build. Thx !
Status: RESOLVED → VERIFIED

Updated

9 years ago
Assignee: srgchrpv → nobody
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-flash
Version: Trunk → 5.x
(Assignee)

Updated

8 years ago
Crash Signature: [@ libc.so.6]

Comment 16

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 5.x → unspecified
You need to log in before you can comment on or make changes to this bug.