Closed Bug 1265173 Opened 5 years ago Closed 5 years ago

Broken background colors active tab and urlbar

Categories

(Firefox :: Theme, defect)

46 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 49
Tracking Status
firefox46 --- wontfix
firefox47 --- fixed
firefox48 --- fixed
firefox49 --- fixed

People

(Reporter: yeger9, Assigned: dao, NeedInfo)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160414152344

Steps to reproduce:

Default


Actual results:

Broken background colors active tab and urlbar


Expected results:

Acrive (current) tab background and urlbar background should be lighter
Component: Untriaged → Theme
J, please attach a screenshot showing how those colors are broken on your system.
Flags: needinfo?(yeger9)
Now: http://paste.opensuse.org/images/54627096.png
Simulation "before": http://paste.opensuse.org/images/41943032.png
Flags: needinfo?(yeger9)
For example Firefox 46 b4: http://paste.opensuse.org/images/71230952.png (all Ok)
This was changed in bug 1244500 in response to people with exactly the opposite complaint: that the lightness was inappropriate on dark themes. I don't use a dark theme day-to-day, but I would tend to agree that keeping the theme darker would be more appropriate than the lightness that we used previously, and that there were contrast issues with text on the half-light grey background that resulted previously.

Did you file this "just" because there is a change, or do you have concrete problems with the new design?
Blocks: 1244500
Flags: needinfo?(yeger9)
As you probably noticed, this build based on GTK3, but tabs are not used native view. And now they are even not the same as in previous versions. All of this is a bad change.
Flags: needinfo?(yeger9)
(In reply to :Gijs Kruitbosch from comment #4)
> Did you file this "just" because there is a change, or do you have concrete
> problems with the new design?

IMHO it looks objectively worse because there's less contrast between tabs and other toolbars, making the UI hierarchy less clear.

I think bug 1244500 went too far with the 5% opacity. This used to be 40% with a fade to transparent before we made it flat. So for the flat background 20% opacity would be my obvious and conservative choice, but maybe 15 or 10% would work too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mdeboer)
Keywords: regression
(In reply to Dão Gottwald [:dao] from comment #6)
Could be worse, but I was 'following' Stephens' decision there. Let's ask him if he agrees with changing it again to something more contrast-y.

Stephen, what do you think of an opacity change from 5% --> 10%/15%/20% for the active tab and navbar?
Flags: needinfo?(mdeboer) → needinfo?(shorlander)
Attached patch patch (obsolete) — Splinter Review
I personally prefer 20%, but using 15% here as a compromise.
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Attachment #8746019 - Flags: review?(mdeboer)
Attached patch patchSplinter Review
now really using 15%
Attachment #8746019 - Attachment is obsolete: true
Attachment #8746019 - Flags: review?(mdeboer)
Attachment #8746020 - Flags: review?(mdeboer)
Comment on attachment 8746020 [details] [diff] [review]
patch

Review of attachment 8746020 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8746020 - Flags: review?(mdeboer) → review+
Flags: needinfo?(shorlander)
https://hg.mozilla.org/mozilla-central/rev/03eac758d8d7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Comment on attachment 8746020 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1244500
[User impact if declined]: insufficient contrast between tabs toolbar and other toolbars
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: trivial patch, very low risk
[String/UUID change made/needed]: none
Attachment #8746020 - Flags: approval-mozilla-beta?
Attachment #8746020 - Flags: approval-mozilla-aurora?
Hello J, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(yeger9)
Comment on attachment 8746020 [details] [diff] [review]
patch

Recent regression (since 46), Aurora48+, Beta47+
Attachment #8746020 - Flags: approval-mozilla-beta?
Attachment #8746020 - Flags: approval-mozilla-beta+
Attachment #8746020 - Flags: approval-mozilla-aurora?
Attachment #8746020 - Flags: approval-mozilla-aurora+
What is it?? White tab on gray tabbar?
Flags: needinfo?(yeger9)
Flags: qe-verify+
Hi J,
Could you please tell us what is the theme you used when you first saw this issue?
Also, could you verify that this was fixed in the following build?
http://archive.mozilla.org/pub/firefox/candidates/47.0-candidates/build1/linux-x86_64/en-US/

I have tried reproducing this myself but I haven't found a theme that reproduces this issue as you described it. It would really help to know.
Thank you.
Flags: needinfo?(yeger9)
You need to log in before you can comment on or make changes to this bug.