Closed Bug 126521 Opened 19 years ago Closed 19 years ago

'view source' shows cached source, bad if page is dynamic

Categories

(Core :: Web Painting, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 55583

People

(Reporter: gatha, Assigned: kmcclusk)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020208
BuildID:    2002020811

the url referenced is a dynamic page generated from a form on itself. problem is
that the view source command only shows the source for the initial, 0-state page
(I am assuming that the source is cached as to avoid an extra http connection to
the server just to get the source). The problem with this is when I'm viewing a
dynamic page, when I complete and submit the form which posts to the same url,
the cached source is not renewed - so new html is displayed in the browser, but
not in the source viewer.

Reproducible: Always
Steps to Reproduce:
1. view source.
2. put some info in the form and hit submit.
3. view source again.


Actual Results:  note that the second time you hit 'view source', you get the
same source as the first time, while the look and code of the actual page is
different.

Expected Results:  should have refreshed the source code every time the page
itself is refreshed in the browser window, perhaps, as to display real source code.
Help/Qa/known Bugs -> #1

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.