aljazeera.net - Mozilla Does not show sidebar frame (document.all)

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
4 years ago

People

(Reporter: mkassim, Unassigned)

Tracking

Details

(Whiteboard: [bug248549fixed], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.8+) Gecko/20020217
BuildID:    2002021708

Mozilla Does not show sidebar frame

Reproducible: Always
Steps to Reproduce:
1. visit this site!
2.
3.
no DNS entry for me...

Comment 2

17 years ago
I think the correct URL is http://aljazeera.net.  On IE 6.0, you get a sidebar
on the righthand side of the page.  Mozilla does not show said sidebar.  Viewing
the page source may be hazardous to your health.

Comment 3

17 years ago
*** Bug 126525 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
page uses document.all to view those menus, tech evang

Comment 5

17 years ago
oops, btw, os = all and update the url

Comment 6

17 years ago
Moving to Tech evangelism and confirming.
Assignee: trudelle → momoi
Component: XP Apps → Middle Eastern
OS: Mac System 9.x → All
Product: Browser → Tech Evangelism
QA Contact: sairuh → xslf
Hardware: Macintosh → All
Version: other → unspecified

Comment 7

17 years ago
there's a bug in bugzilla, the "and confirm bug (change status to NEW) "
checkbox doesn't work.
Marking as new
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Summary: Mozilla Does not show sidebar frame → aljazeera.net: Mozilla Does not show sidebar frame
*** Bug 137599 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 191687 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
From bug 191687:
Error: document.all has no properties
Source File: http://aljazeera.net/j-scripts/menu.js
Line: 399

Comment 11

16 years ago
There is an additional problem with viewing this site:

Clicking on any of the articles, I get the title but not the story, which is
visible in the source.

Computer info: Moz 1.3, Win98, PIII

Comment 12

16 years ago
Mac OSX Camino
Problem with aljazeera articles also seen in Chimera 0.6 (Build 2002122004) and
Camino Build 2003041205
Please try loading http://english.aljazeera.net/
Then click on any of the topics. The title loads but the article text does not.
Works fine in IE

The page source has the following javascript which might be the source of the
problem.

<script language="JavaScript1.2">
var nav = document.parentWindow.navigator;
if (nav.appName == "Microsoft Internet Explorer")
{
if( document.all.date 1)
{
docDate = document.all.date1.value;
}
}
else
{
if( document.getElementById("date1") )
{
docDate = document.getElementById("date1").value;
}
}

</script>

Comment 13

16 years ago
Created attachment 121569 [details]
Email to feedback of aljazeera

I have sent this email to aljazeera, to also make them think about the problem

Btw, I tried the english pages and no clicking on subjects will show anything.
Clicking on the arabic page though shows the new page (using mozilla 1.2 coming
from redhat 9)

Hope this helps and thanks to all who work somehow on this.

Comment 14

16 years ago
Other than the "document.all" problem, there is also a case of using JavaScript
"unescape" on their Arabic menu titles. 

I'm not so sure why they're actually doing that, but the results would most
likely be in Latin instead of Arabic. (see mozilla bug 200984)
Depends on: 200984

Comment 15

16 years ago
arabic evangelism
Assignee: momoi → arabic
Component: Middle Eastern → Arabic

Comment 16

16 years ago
wrong config over there it seems

Comment 17

15 years ago
The problem(s) persists even with 1.5RC1 - what's the status of this bug ?  IE
seems for function properly.

Comment 18

15 years ago
re:comment 17, this is evangelism bug, so it's not a bug in
mozilla. The non-standard "document.all" is being used everywhere on
aljazeera.

Also, an hour ago, I sent an e-mail to aljazeera through their
"netsupport" address (they seem to have more than one support
address). If no change and no reply in the next couple of days I'll
probably try the other addresses as well.

Comment 19

15 years ago
*** Bug 236154 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
same problem in firefox 0.8
*** Bug 243236 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
*** Bug 244543 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
*** Bug 245514 has been marked as a duplicate of this bug. ***

Comment 24

15 years ago
This is a serious and important issue that seems to have been reported at
least half a dozen times in one incarnation or another for approximately
two years now.  Beyond branding it as an 'evangelical' bug (which I'm not
quite sure what that means) can someone point out a definite reason why
this issue is still an issue even with Firefox-0.9.2 ?

If this is the site's problem, is it unique to this site or a common enough
mistake to where a "this site is non-conforming" button ought to be considered
to at a min allow the users to view it ?  If they are not following the 
standard, could someone point out exactly what it is that they are doing wrong 
for us to harp on them to change it.

For the record the site in question is http://www.aljazeera.net

Comment 25

15 years ago
tech evang means its not mozillas fault, but the site should get a webdesigner
that knows what hes doing, or the site owner simply doesnt care for anything but
IE compliance ;-)

... visit their site, then go Tools -> Web Development -> Javascript Console
you will see alot of dhtml/js/layer related errors pop up.

the site still uses document.all which is a pre DOM standard Jsciprt specific
relict and shouldnt be around since the year 2000 anymore.

so, they only care for IE or they dont know any better.

beside that, there is 360 html errors ;-)

http://validator.w3.org/check?uri=http%3A%2F%2Fwww.aljazeera.net%2F&charset=%28detect+automatically%29&doctype=Inline&verbose=1
*** Bug 251560 has been marked as a duplicate of this bug. ***

Comment 27

15 years ago
This is now fixed in latest nighties. (See bug 248549 for details)

--> FIXED
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 28

15 years ago
Sorry about the spam.

Since there seems to be no official stance on how to resolve these
"document.all" evangelism bugs, I'm reopening this one for now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: aljazeera.net: Mozilla Does not show sidebar frame → aljazeera.net: Mozilla Does not show sidebar frame (document.all)

Comment 29

15 years ago
-> wfm 
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Whiteboard: [bug248549fixed]

Comment 30

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: aljazeera.net: Mozilla Does not show sidebar frame (document.all) → aljazeera.net - Mozilla Does not show sidebar frame (document.all)
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.