NS_ERROR_STORAGE_CONSTRAINT thrown when trying to set keyboard for bookmark

RESOLVED DUPLICATE of bug 1150678

Status

()

Toolkit
Places
RESOLVED DUPLICATE of bug 1150678
2 years ago
a year ago

People

(Reporter: Unfocused, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When trying to see a keyword for a bookmark (via the Library window), I'm getting the following exception thrown:


NS_ERROR_STORAGE_CONSTRAINT: Component returned failure code: 0x80630003 (NS_ERROR_STORAGE_CONSTRAINT) [nsINavBookmarksService.setKeywordForBookmark] PlacesUtils.jsm:3452
NS_ERROR_STORAGE_CONSTRAINT: Component returned failure code: 0x80630003 (NS_ERROR_STORAGE_CONSTRAINT) [nsITransactionManager.doTransaction] PlacesUtils.jsm:2042
    .doTransaction.value() PlacesUtils.jsm:2042
    onKeywordFieldChange() editBookmarkOverlay.js:631
    onchange() places.xul:1


The keyword isn't set.
Yeah, we don't allow setting different keywords for the same url (unless the post data differs), and the keywords UI is completely broken atm, so you can end up with "zombie" keywords that may disallow inserting new one.
This is related to bug 1150678.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
You need to log in before you can comment on or make changes to this bug.