[Widevine] After the "Widevine" plugin is re-enable, the video does not start

RESOLVED DUPLICATE of bug 1264832

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1264832
2 years ago
2 years ago

People

(Reporter: CosminMCG, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(1 attachment)

Created attachment 8742320 [details]
video of the issue

[Affected versions]:
- User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
- User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
- Build ID: 20160417030601

[Affected Platforms]:
- All Windows
- All Mac OS

[Prerequisites]:
- Widevine latest version is installed.
- Only Widevine CDM plugin is enabled.
- User-Agent Switcher add-on is installed (https://goo.gl/FKb70f) and it is set to fake Chrome User Agent.

[Steps to reproduce]:
1. Go to http://goo.gl/dhyOMb and play the video (the video starts playing through Widevine CDM).
2. Open in a new tab "about:addons -> Plugins section" and disable the "Widevine" plugin.
3. Go to the video and refresh the website.
4. Go back to "about:addons -> Plugins section" and re-enable the "Widevine" plugin.
5. Return to the video page and refresh the website.

[Expected results]:
- The video starts to play.

[Actual results]:
- After you re-enable the "Widevine" plugin the video will not start. The user is instructed to install Silverlight plugin although Widevine CDM is enabled.
- Sometimes you have to refresh the page a few times or restart the browser until the video is streamed correctly through Widevine CDM.  

[Notes]:
- This issue is not reproducible in Google Chrome.
- This issue is reproducible with most of the websites that use Widevine CDM.
Should be fixed in bug 1264832.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1264832
You need to log in before you can comment on or make changes to this bug.