Perform linear interpolation when computing the SetValueCurveAtTime events

RESOLVED FIXED in Firefox 52

Status

()

P2
normal
Rank:
25
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: padenot, Assigned: dminor)

Tracking

(Depends on: 1 bug)

Trunk
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
We used to just sample the curve, but the working group has agreed on linear interpolation.

Spec changes at https://github.com/webaudio/web-audio-api/commit/b6acfabccbd60f704c4e98101ddfef39eb987acf.
(Assignee)

Updated

3 years ago
Priority: -- → P2
Rank: 25
Depends on: 1184057
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1258227
(Assignee)

Comment 2

2 years ago
Wasted at least 30 minutes this morning wondering why the values weren't being interpolated in my test case, so I'm going to fix this one now.
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Reporter)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8803958 [details]
Bug 1265401 - Perform linear interpolation when computing the SetValueCurveAtTime events;

https://reviewboard.mozilla.org/r/88142/#review87368
Attachment #8803958 - Flags: review?(padenot) → review+

Comment 5

2 years ago
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64293caeec1e
Perform linear interpolation when computing the SetValueCurveAtTime events; r=padenot

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/64293caeec1e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
(Assignee)

Updated

2 years ago
Depends on: 1313058
You need to log in before you can comment on or make changes to this bug.