Closed Bug 1265456 Opened 4 years ago Closed 4 years ago

aliases mostly don't work for builds

Categories

(Taskcluster :: Services, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1247703

People

(Reporter: sfink, Unassigned)

References

Details

(Whiteboard: [intree])

commit_parser.py accepts aliases for builds, but using them is unlikely to do what you want. If I'm reading the code correctly, you can use them for trivial 1-1 aliases (eg lx: linux64), but any use of patterns (eg lx: /linux/) will just ignore the alias because the resulting substition is not matched against the existing builds in the way that tests are. (handle_alias is never called, and in fact that function is totally test-specific.)

It would make more sense to remove normalize_platform_list entirely, or make it error out for anything other than a simple alias.

Then again, it sounds like dustin is rewriting this stuff, so I'm really just filing this bug to document the issue. Hopefully it can be ignored and then closed as INVALID when the new system comes online.
Component: General → Integration
Whiteboard: [intree]
I noticed that too.  In fact, there's whole stacks of stuff that code purports to do but does not actually accomplish.

So, yeah, we can close this now or after bug 1247703 lands, either way.
Depends on: 1247703
Seems like a minor thing that'll just go away since you're aware of it, so I vote for killing this bug now. Maybe I'll dupe it. (Not really correct, since it should be "fixed by" not "duplicate of". But at least the bug will go away.)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247703
Component: Integration → Services
You need to log in before you can comment on or make changes to this bug.