Closed Bug 12655 Opened 21 years ago Closed 20 years ago

Pressing Tab in forms with focus in single-line text control does not advance to next field

Categories

(Core :: XUL, defect, P3, major)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: buster)

References

()

Details

Build ID: 1999082616 (GFX enabled in prefs)
Platform: Windows NT (will look at Mac OS and Linux later)

To reproduce:
- Launch apprunner, make sure prefs have GFX enabled
- Load the above URL
- Click in a text input control
- Press Tab

Result: nothing happens.

Expected result: you should move on to the next text input field.
OS: Windows NT → All
Hardware: PC → All
Also a problem on Linux. Changing bug to all platforms, all OSes.
Assignee: trudelle → kmcclusk
Not an xptoolkit issue, reassigning to kmcclusk, cc buster
Assignee: kmcclusk → buster
Steve, not sure if this is you or Tom Pixley. Reassigning to you.
Target Milestone: M12
this is a bug fix I'll get in for M12.
*** Bug 13702 has been marked as a duplicate of this bug. ***
Blocks: 9814
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Summary: Pressing Tab in forms does not advance to next field → Pressing Tab in forms with focus in single-line text control does not advance to next field
fixed.  there's still some debate about how multi-line text controls should
work, but this works for single-line text controls properly
Sorry for spam, re-assigning phillip's QA contact XPToolkit/XPWidget bugs to
claudius due to restructure
QA Contact: claudius → ckritzer
Marking VERIFIED FIXED on:
- Linux6 2000-03-01-13 Commercial build
- MacOS9 2000-03-01-13 Commercial build
- Win98 2000-03-01-16 Commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.