Windows support for sscache

RESOLVED DUPLICATE of bug 1316329

Status

RESOLVED DUPLICATE of bug 1316329
2 years ago
2 years ago

People

(Reporter: selenamarie, Unassigned)

Tracking

Details

We need to support object directory caching.

We need to test this and explore anything additional we need to do to provide it. Might just be a build config setting.
I think we use ccache rather than sccache for Windows. I'm not sure what sscache is.

See https://hg.mozilla.org/mozilla-central/file/ae7413abfa4d/build/mozconfig.cache#l47

Mike, can you confirm? Thanks!
Flags: needinfo?(mh+mozilla)
Sorry, re-reading, I think this means we don't use any object directory caching for Windows at all. If that's the case, maybe this bug isn't needed?
sccache works on windows ; ccache does not. In fact, Windows builds are supposed to be using sccache already.
Flags: needinfo?(mh+mozilla)

Comment 4

2 years ago
Pete, not sure if this helps, but I've been looking at this a little bit for our linux builds and will be trying some things out this week.

From what I gathered it requires:
1. S3 buckets within our account
2. Credentials that can access that bucket available within the task environment (the queue can give out creds based on scopes for s3 buckets).  Not sure where those creds need to be at the moment though.
3. Edit in-tree mozconfig file for the cache https://dxr.mozilla.org/mozilla-central/source/build/mozconfig.cache
4. set right environment variables when executing the task so sccache is used.
Coop - can you confirm whether or not we use sccache in buildbot for Windows?
Flags: needinfo?(coop)
(In reply to Selena Deckelmann :selenamarie :selena from comment #5)
> Coop - can you confirm whether or not we use sccache in buildbot for Windows?

We do, but it's installed/invoked via mozharness. Here's an example log from inbound:

http://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-win32/1462885595/mozilla-inbound-win32-bm74-build1-build755.txt.gz
Flags: needinfo?(coop)
Component: Integration → Platform and Services

Updated

2 years ago
See Also: → bug 1000713
This got fixed in bug 1316329.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1316329
You need to log in before you can comment on or make changes to this bug.