Problem displaying http://salamanstra.keenspot.com/ with E10S off

RESOLVED DUPLICATE of bug 1265256

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 1265256
2 years ago
2 years ago

People

(Reporter: B.J. Herbison, Unassigned)

Tracking

({regression})

48 Branch
Unspecified
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-, firefox47 unaffected, firefox48+ fixed, firefox49+ fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(6 attachments)

(Reporter)

Description

2 years ago
Created attachment 8742537 [details]
Display on load

Steps to reproduce:
1) Turn off E10S ("Enable multi-process Nightly) and restart.
2) Visit http://salamanstra.keenspot.com/ .
3) Press Page Down three times (or more for a shorter window).
4) Press Home.

Expected results:
o  The same display as with Firefox 45.0.1 or Nightly with E10S enabled.
o  No messages on the console.

Actual results:
o  Portions of the comic image are repeated several times. See attached screen  shots. HS0 is the inital diaplay, HS1, HS2, and HS3 after one, two, and three presses of Page Down, and HShome after pressing home.
o  Messages appeared on the console. The exact messages varied from try to try.

One attempt:
[GFX1-]: Invalid draw target(s) 0x7f3e678d0880 and 0
[GFX1-]: Invalid draw target(s) 0x7f3e724aab00 and 0

Another attempt:
[GFX1-]: Invalid draw target(s) 0x7fb5a71aa2a0 and 0
[GFX1-]: Invalid draw target(s) 0x7fb5a4836200 and 0
[GFX1-]: Invalid draw target(s) 0x7fb59b8efba0 and 0
[GFX1-]: Invalid draw target(s) 0x7fb593db8ec0 and 0
[GFX1]: Unknown cairo format -1
[GFX1]: Unknown image format 11
[GFX1]: Unknown cairo format -1
[GFX1]: Unknown image format 11
[GFX1-]: Invalid draw target(s) 0x7fb5a9469240 and 0

Roughly the same results with an exiting profile and a new profile. The window looked the same and the messages appeared similar.

I tried saving a local copy of the web site to produce a reduced test case but the saved version of the page didn't display correctly and I wasn't able to reproduce this display problem.

I don't know when this problem occurred. I reproduced the problem after it was mentioned by Stephen Rovinsky <srovo01@yahoo.com> on the Nightly Testers mailing list. On 15 April Steve said the problem had been happening for "the past few days".

Steve saw the problem with Windows Home Vista, 32-bit. I reproduced the problem with Ubuntu Linux (64-bit).

about:support output below.

Application Basics
------------------

Name: Firefox
Version: 48.0a1
Build ID: 20160418030305
Update Channel: nightly
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
OS: Linux 4.2.0-35-generic x86-64
Multiprocess Windows: 0/3 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Plus
Version: 2.7.2
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Firefox Hello
Version: 1.2.6
Enabled: true
ID: loop@mozilla.org

Name: Image Zoom
Version: 0.6.3.1-signed
Enabled: true
ID: {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}

Name: keyconfig
Version: 20110522
Enabled: true
ID: keyconfig@dorando

Name: Multi-process staged rollout
Version: 1.0
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0
Enabled: true
ID: firefox@getpocket.com

Name: Saved Password Editor
Version: 2.9.6
Enabled: true
ID: savedpasswordeditor@daniel.dawson

Name: Simple Form Fill
Version: 1.0.4
Enabled: true
ID: simpleformfill@sblask

Name: Social Fixer
Version: 12.0
Enabled: true
ID: socialfixer@mattkruse.com

Name: Ubuntu Modifications
Version: 3.2
Enabled: false
ID: ubufox@ubuntu.com

Graphics
--------

Features: Basic

Features: none

Features: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile

Features: No


Features: Yes

Features: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile

Features: Intel Open Source Technology Center

Features: Mesa DRI Intel(R) Haswell Mobile

Features: 3.0 Mesa 11.0.2



Features: 0

Features: skia

Features: cairo

Features: none

Features: 0


Features: Unknown cairo format -1

Features: Unknown cairo format -1

Features: Unknown image format 11

Features: Unknown cairo format -1

Features: Unknown image format 11

Features: Invalid draw target(s) 0x7f3d04809420 and 0

Features: Unknown cairo format -1

Features: Unknown image format 11

Features: Unknown cairo format -1

Features: Unknown image format 11

Features: Invalid draw target(s) 0x7f3d18f6a3e0 and 0

Features: Unknown cairo format -1

Features: Unknown image format 11

Features: Unknown cairo format -1

Features: Unknown image format 11

Features: Invalid draw target(s) 0x7f3d0ce1fca0 and 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 1
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20160418030305
browser.startup.homepage: about:blank
browser.startup.homepage_override.buildID: 20160418030305
browser.startup.homepage_override.mstone: 48.0a1
browser.tabs.maxOpenBeforeWarn: 30
browser.tabs.remote.autostart.2: false
browser.tabs.warnOnClose: false
browser.tabs.warnOnOpen: false
browser.urlbar.suggest.searches: true
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
dom.push.userAgentID: 78c1b375733f4dfcaaecd47b6dd7de24
extensions.lastAppVersion: 48.0a1
font.internaluseonly.changed: false
gfx.crash-guard.glcontext.appVersion: 43.0a1
gfx.crash-guard.glcontext.deviceID: Mesa DRI Intel(R) Haswell Mobile
gfx.crash-guard.glcontext.driverVersion: 3.0 Mesa 10.5.9
gfx.crash-guard.status.glcontext: 2
media.gmp-gmpopenh264.abi: x86_64-gcc3
media.gmp-gmpopenh264.lastUpdate: 1450744062
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 20160418030305
media.gmp-manager.lastCheck: 1461015272
media.webrtc.debug.aec_log_dir: /tmp
media.webrtc.debug.log_file: /tmp/WebRTC.log
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1460984659
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
plugin.state.librhythmbox-itms-detection-plugin: 0
print.print_bgcolor: false
print.print_bgimages: false
print.print_duplex: 0
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name: na_letter
print.print_paper_size_type: 1
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_resolution: 300
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 56
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 25
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
security.ssl.errorReporting.automatic: true
services.sync.declinedEngines: adblockplus
services.sync.engine.addons: false
services.sync.engine.prefs: false
services.sync.engine.prefs.modified: false
services.sync.lastPing: 1460377314
services.sync.lastSync: Mon Apr 11 2016 09:38:49 GMT-0400 (EDT)
services.sync.numClients: 2
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1458518768

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC:

Accessibility
-------------

Activated:
Prevent Accessibility:

Library Versions
----------------

Experimental Features
---------------------

Sandbox
-------
(Reporter)

Comment 1

2 years ago
Created attachment 8742538 [details]
Display after pressing Page Down once
(Reporter)

Comment 2

2 years ago
Created attachment 8742540 [details]
Display after pressing Page Down twice
(Reporter)

Comment 3

2 years ago
Created attachment 8742541 [details]
Display after pressing Page Down three times
This sounds very similar to bug 1265256. I suspect it is the same issue. Did this regress between the april 7 and april 8 nightlies? That would go a long way to confirming they are the same issue.
Flags: needinfo?(bj)
Marking dependency speculatively for now, we can remove if they are different issues.
Depends on: 1265256
(Reporter)

Comment 6

2 years ago
Created attachment 8742544 [details]
And finally press Home
Flags: needinfo?(bj)
Depends on: 1263480
No longer depends on: 1265256
(Reporter)

Comment 7

2 years ago
The behavior has changed with the 19 April Nightly, but the basic problem is not fixed.

The comic image is still repeated. The changes are:
* The "Tweets" section of the page is now on top of the comic.
* When I scroll down and press Home the comic image is no longer displayed at the top of the page.

Comment 8

2 years ago
Created attachment 8742821 [details]
glitch screenshot

I can confirm that the problem is not fixed on Latest Nightly[1] with HWA and e10s BOTH disabled.


[1] 
https://hg.mozilla.org/mozilla-central/rev/ae7413abfa4d3954a6a4ce7c1613a7100f367f9a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160419030312
status-firefox47: --- → ?
Keywords: regression

Updated

2 years ago
tracking-e10s: --- → -

Updated

2 years ago
Blocks: 852754
BJ, can you please confirm if this happens with Firefox 47?
Flags: needinfo?(bj)
Whiteboard: [gfx-noted]
(Reporter)

Comment 10

2 years ago
I installed Firefox 47.0a2 (2016-04-19). The page http://salamanstra.keenspot.com/ displays correctly with and without E10S enabled.
Flags: needinfo?(bj)
I think this is a dupe of Bug 1265256. It has the same regression range on mozilla-inbound, same STR, and the same corruption pattern.
[Tracking Requested - why for this release]:

(In reply to Matthew Turnbull [Bluefang] from comment #11)
> I think this is a dupe of Bug 1265256. It has the same regression range on
> mozilla-inbound, same STR, and the same corruption pattern.

It certainly looks similar and may just be another symptom of the regression. I'm adding that bug to the See Also list so they're connected. We should probably track this since it's a regression.
status-firefox47: ? → unaffected
tracking-firefox48: --- → ?
See Also: → bug 1265256
Version: Trunk → 48 Branch
Tracking for 48+.
status-firefox49: --- → affected
tracking-firefox48: ? → +
tracking-firefox49: --- → +
There is a possible fix in bug 1262556 so we may try uplifting that to 48.
Bug 1262556 seems to have been uplifted to 47 a while ago, do we have the right bug number?
I see, it's the bug from comment 11, not comment 14.  Bug 1265256 has now been uplifted to 48.  Are we ready to mark this a duplicate?
(Reporter)

Comment 17

2 years ago
No problems observed on the site with Nightly. No reason to believe the problem wasn't fixed with bug 1265256.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1265256
status-firefox48: affected → fixed
status-firefox49: affected → fixed
You need to log in before you can comment on or make changes to this bug.