Closed Bug 1265604 Opened 4 years ago Closed 4 years ago

Single AccessibleCaret in empty <input> displayed as leaning vs. vertical caret

Categories

(Firefox for Android :: Text Selection, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: capella, Unassigned)

References

(Blocks 1 open bug)

Details

As (belatedly) promised, the STR for this ... is simple [0]

) Tap into empty <input>
) Type text
) Tap again to display caret |handle_middle.png|
) Tap care to display ActionBar
) Tap Select ALL
) Tap backspace
) Observe |handle_start.png|

[0] https://www.dropbox.com/s/240no5etitmqpor/caretTilt_bug.mp4?dl=0
The key to reproduce this issue to use swift keyboard with the steps in comment 0. I cannot reproduce the issue with the built-in Google keyboard.

And If I turn off "layout.accessiblecaret.allow_script_change_updates", it's not reproducible with swift keyboard either. So I guess with swift keyboard, we'll get extra selection change with reason 0 and update the carets in [1]. In this cases, the first caret position is not updated, which makes the first caret remain tilt and visible.

[1] https://dxr.mozilla.org/mozilla-central/rev/67ac40fb8f680ea5e03805552187ba1b5e8392a1/layout/base/AccessibleCaretManager.cpp#158-161
Well, I can't seem to repro this anymore.
I can't reproduce this, either. I was wondering which commit fixed this :)
And the answer is ...........

Bug 1249201 - Continue showing AccessibleCaret when scrolling or panning the page
https://hg.mozilla.org/mozilla-central/rev/989e88261527
What a surprise! Mark, thank you for bisecting the change. Let's close this bug :)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.