build is stuck with ERROR!! RequestSyncService - Failed to retrieve data from the database.

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
a year ago

People

(Reporter: wolfiR, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
My build of Thunderbird 45.0 is stuck with:
[ 1886s] resource://gre/modules/services/datareporting/policy.jsm
[ 1886s] resource://gre/modules/sessionStoreManager.js
[ 1886s] resource://gre/modules/socket.jsm
[ 1886s] resource://gre/modules/sqlite/sqlite_internal.js
[ 1886s] resource://gre/modules/summaryFrameManager.js
[ 1886s] resource://gre/modules/templateUtils.js
[ 1886s] resource://gre/modules/traceHelper.js
[ 1886s] resource://gre/modules/twitter-text.jsm
[ 1886s] resource://gre/modules/virtualFolderWrapper.js
[ 1886s] resource://gre/modules/vtt.jsm
[ 1886s] resource://gre/modules/windowsJumpLists.js
[ 1886s] resource://gre/modules/workers/PromiseWorker.js
[ 1886s] resource://gre/modules/workers/require.js
[ 1886s] resource://gre/modules/xmpp-authmechs.jsm
[ 1886s] resource://gre/modules/xmpp-commands.jsm
[ 1886s] resource://gre/modules/xmpp-session.jsm
[ 1886s] resource://gre/modules/xmpp-xml.jsm
[ 1886s] resource://gre/modules/xmpp.jsm
[ 1886s] resource://gre/modules/yahoo-session.jsm
[ 1886s] ERROR!! RequestSyncService - Failed to retrieve data from the database.
[30694s] qemu: terminating on signal 15 from pid 26807

As you can see it just stops with that error and is killed at some point.
I could build TB 45.0 in another environment but it fails always in the official openSUSE build environment with that error.
(Just for the record: building Firefox 45.0 is no issue)
(Reporter)

Comment 1

3 years ago
hmm, with Firefox 45.0 it just proceeds after that message:

[ 3027s] resource://gre/modules/workers/PromiseWorker.js
[ 3027s] resource://gre/modules/workers/require.js
[ 3027s] ERROR!! RequestSyncService - Failed to retrieve data from the database.
[ 3028s] Executing /home/abuild/rpmbuild/BUILD/obj/dist/bin/xpcshell -g /home/abuild/rpmbuild/BUILD/obj/dist/bin/ -a /home/abuild/rpmbuild/BUILD/obj/dist/bin/browser -f /home/abuild/rpmbuild/BUILD/mozilla/toolkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource://app/");
[ 3028s] resource://app/components/ChromeProfileMigrator.js
[ 3028s] resource://app/components/ExperimentsService.js

So probably it's unrelated to RequestSyncService but cause by something else
have you sorted it out?
Flags: needinfo?(mozilla)
There doesn't appear to be enough information to determine what is going on, and the code has changed significantly in the interim.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mozilla)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.