[RFE] [UE] SSL outgoing emai not default Security Issue

VERIFIED DUPLICATE of bug 97161

Status

MailNews Core
Security: S/MIME
P5
enhancement
VERIFIED DUPLICATE of bug 97161
17 years ago
9 years ago

People

(Reporter: jg, Assigned: Stephane Saux)

Tracking

1.0 Branch
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205
BuildID:    2002020511

I created a new profile and hte outoging email setting was not set right  IMO

Use secure SSL connection for outgoing mail, this should be "When available" as
the default setting IMO

Reproducible: Always
Steps to Reproduce:
1.Check the outgoing email settins
2.
3.

Actual Results:  Not set to "When available"

Expected Results:  should be "When available" as the default setting IMO

Comment 1

17 years ago
->mailnews
Assignee: new-network-bugs → mstoltz
Component: Networking → Security: General
Product: Browser → MailNews
QA Contact: benc → junruh

Comment 2

17 years ago
Enhancement.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P5
Hardware: PC → All
Summary: SSL outgoing emai not default Security Issue → [RFE]SSL outgoing emai not default Security Issue
Target Milestone: --- → Future
->PSM s/MIME
Assignee: mstoltz → ssaux
Component: Security: General → S/MIME
Product: MailNews → PSM
QA Contact: junruh → alam
Version: other → 2.2

Updated

17 years ago
QA Contact: alam → carosendahl

Comment 4

16 years ago
How would client auth fit into this picture if the default was set to whenever
possible, the server was configured for SSL connections & required client auth,
but the user did not yet have a cert set up for client auth?

Would defaulting to connect via SSL whenever possible still be the desirable
default?
Summary: [RFE]SSL outgoing emai not default Security Issue → [RFE] [UE] SSL outgoing emai not default Security Issue

Comment 5

16 years ago
This bug confuses me.

Is this bug about S/Mime email messages?
Or is it about SSL connections?

SSL has nothing to do with S/Mime.

Please describe more clearly what you are suggesting.

Comment 6

16 years ago
I believe the reporter is requesting that IMAP and SMTP should default to when
possible instead of never/no for the SSL setting in the mail prefs.
(Reporter)

Comment 7

16 years ago
what mime thing are you confused about?
i've never mentioned it
its simple to do just change the current default to "use SSL smtp if available"
no hastle what so ever
JG

Comment 8

16 years ago
Ah, I see, thanks for giving more details. I guess I was confused, because you
assigned this bug to component S/Mime, but were talking about SSL.

So you are requesting, in a new user profile, the SMTP option should default to
"when available".

Actually, there is already such a bug. Marking as a duplicate.


*** This bug has been marked as a duplicate of 97161 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
verified dup
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: S/MIME → Security: S/MIME
Product: PSM → Core

Updated

10 years ago
Version: psm2.2 → 1.0 Branch

Updated

9 years ago
Component: Security: S/MIME → Security: S/MIME
Product: Core → MailNews Core
QA Contact: carosendahl → s.mime
You need to log in before you can comment on or make changes to this bug.