Closed Bug 1265703 Opened 8 years ago Closed 8 years ago

telemetry-alert: median SERVICE_WORKER_LIFETIME decreased dramatically on or around 2016-02-20

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: chutten, Unassigned)

References

Details

(Whiteboard: btpp-active)

Alert: http://alerts.telemetry.mozilla.org/index.html#/detectors/1/metrics/1336/alerts/?from=2016-02-20&to=2016-02-20

Changeset: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9166484e331b685c8b7027bedcf328421029ac59&tochange=69ec3dc408a2a720cb2b8210fea33e3504aeec22

Evolution: http://mzl.la/1SX5Ryk

It appears as though SERVICE_WORKER_LIFE_TIME decreased on or around Feb 20. (Sorry for the delay in filing. Our alerts system had a fault which delayed reports for several weeks). I don't know if this is a regression or an improvement, but it is a sudden and measurable change.
So I think this may just be a consequence of bug 1246319.  Before I fixed that it was possible for people to build up multiple service worker scripts for the same scope.  So if the service worker was unregistered it would just keep coming back.  After this fix it became easier for service workers to actually get removed.

I'm a bit surprised by the impact to overall telemetry, but it might make sense that fixing the removal of service workers would reduce overall life time.
Blocks: 1246319
Its possible that this is also related to Boris fixing some of the busy count stuff on workers in bug 1249102.
Blocks: 1249102
Need info myself to check and see if our grace timer is still working.  That is really the only thing that could be wrong here, I think.
Flags: needinfo?(bkelly)
Whiteboard: btpp-active
I verified locally that the idle grace timer is working.  In fact, I believe the grace timer was probably broken until Boris landed bug 1249102. due to the worker busy count.  We were keeping the worker alive until the window was closed or we hit the hard 5 minute timeout.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(bkelly)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.