Closed Bug 1265718 Opened 4 years ago Closed 3 years ago

Decouple fronts from actors in animation inspector.

Categories

(DevTools :: Inspector: Animations, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 49
Iteration:
49.3 - Jun 6

People

(Reporter: ejpbruel, Assigned: ejpbruel)

References

Details

Attachments

(2 files)

No description provided.
Depends on: 1265429
Blocks: 1263289
Severity: normal → enhancement
Whiteboard: [devtools-html]
Flags: qe-verify-
Priority: -- → P2
Assignee: nobody → ejpbruel
Status: NEW → ASSIGNED
Iteration: --- → 49.2 - May 23
Priority: P2 → P1
Attachment #8751326 - Flags: review?(jryans) → review+
Attachment #8751327 - Flags: review?(jryans) → review+
Try push for the patch to decouple AnimationPlayerFront from AnimationPlayerActor:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b3483dbe4173
Previous try push for patch to decouple AnimationPlayerFront from AnimationPlayer had test failures due to capitalisation errors. New try push with issues addressed:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fefef0a85b11
Keywords: leave-open
Try push for patch to decouple AnimationPlayerFront from AnimationPlayer looks good, but I had to rebase over some ESLint fixes. Here's another try push to make sure I didn't break anything during rebase:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=941b520f902f
Try push for the patch to decouple AnimationsFront from AnimationsActor:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fb05e74ab75b
sorry had to back this out for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=9491138&repo=fx-team
Flags: needinfo?(ejpbruel)
Try push for the patch to decouple AnimationsFront from AnimationsActor:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d54ab0f97b12
Flags: needinfo?(ejpbruel)
backed out again for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=9526403&repo=fx-team
Flags: needinfo?(ejpbruel)
Iteration: 49.2 - May 23 → 49.3 - Jun 6
I fixed the test errors that were the cause for the last backout. Let's hope the patch sticks this time.
Flags: needinfo?(ejpbruel)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: leave-open
Resolution: --- → FIXED
Blocks: 1277706
No longer blocks: 1263289
Blocks: 1263289
Whiteboard: [devtools-html]
Target Milestone: --- → Firefox 49
No longer depends on: 1327037
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.