Scrolling is broken on the web

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: gerard-majax, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
 - build and flash pine
 - browse google.com, do a search
 - same on mobile.twitter.com

Expected:
 I can scroll pages

Actual:
 I cannot. There is something scrolling but it is not the content of the web page.

I have spotted the same behavior on recent m-c+master builds: I cannot scroll inside the Twitter *app* but I can on web sites.

Maybe it is related to the issues we see around loadContext/loadInfo ?
(Reporter)

Comment 1

2 years ago
Kats, what should I start checking for about this?
Flags: needinfo?(bugmail.mozilla)
What is pine?
Flags: needinfo?(bugmail.mozilla) → needinfo?(lissyx+mozillians)
(Reporter)

Comment 3

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> What is pine?

this: https://hg.mozilla.org/projects/pine/

But as I said, I also have this on m-c in applications: Youtube, Twitter. Websites on m-c are okay.
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 4

2 years ago
Oh, and it reproduces also on mulet. There, scrolling with the mouse does not scroll the whole page either. But I can achieve this with directionnal keys of the keyboard.
(Reporter)

Comment 5

2 years ago
And this is on B2G.
Ok. Can you turn on the logging in APZCTreeManager.cpp, AsyncPanZoomController.cpp, InputQueue.cpp, APZCCallbackHelper.cpp, get a log of the (not working) scrolling, and attach it to this bug? Thanks.
(Reporter)

Comment 7

2 years ago
Created attachment 8743319 [details]
apz_scroll.log

This is trying to scroll down (then up) on mobile.lemonde.fr
From the log it looks like the scroll attempt goes into overscroll right away, because there's no room to scroll. The sizes of the composition bounds are all 720x1120 or 720x1280 and the scrollable areas are 360x560 or 360x640 (so at 2x scaling they fit exactly in the comp bounds). The APZ side of things seems to be working as intended given the layer information it has. The problem must be on the layout side or in gaia. Can you check to make sure there's no spurious overflow:hidden properties anywhere? I don't think anything on the layout side has changed in this area.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.