If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla locks up when save prompts for overwriting existing file

VERIFIED WORKSFORME

Status

Core Graveyard
File Handling
--
critical
VERIFIED WORKSFORME
16 years ago
a year ago

People

(Reporter: Rudmer van Dijk, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    20020218

mozilla locks up when save prompts for overwriting existing file, both buttons 
cannot be used, dialog (including underlying) cannot be closed and other 
browser windows don't respond to mouse or keboard. However windows do redraw 
and can be raised or lowered. Mozilla has to be closed by killing the first 
instance of mozilla-bin.

Reproducible: Always
Steps to Reproduce:
1. goto a page to download something (eg. 
ftp://ftp.kernel.org/pub/linux/kernel/v2.4/testing/incr/)
2. choose a file to download (eg. patch-2.4.18-rc1-rc2.bz2)
3. choose locations where file already exists (eg. /usr/src)

Actual Results:  mozilla does not respond to user actions as descriped above

Expected Results:  continue to work: if I choose OK, download and overwrite 
file; if I choose cancel, let me specify other filename/path or if I want to 
wait let me use another browser window

Comment 1

16 years ago
Linux file picker issue; sending to Brian.
Assignee: law → bryner
(Reporter)

Comment 2

16 years ago
Some extra info:

build 2002021906 has the same problem and it looks like it is related to
displaying error/warning dialogs. Using the find dialog works, but when the
search phrase cannot be found a warning dialog pops up and mozilla hangs in the
same way as reported above
when started from a terminal this is the last output before mozilla hangs:
-- start --
Same node -- (0, 1)
Will need to pull a new node: restart=0, frag len=1
Loop ...
New node -- Resetting pointers. Deque size is 0
No more deque, looking in tree
:::::::::::::::::::::::::: Got another node >>>> Node: NULL
Iterator gave: >>>> Node: NULL
Clear the deque!
-- end (mozilla hangs) --
I don't see this with build 2002-02-20-08.  Rudmer, what windowmanager are you
using?
(Reporter)

Comment 4

16 years ago
I'm using KDE 2.1.2
That would be the desktop environment, not the window manager....
(Reporter)

Comment 6

16 years ago
just using KDE's default:

rudmer@gandalf:~ # kwin --version
Qt: 2.3.1
KDE: 2.1.2
KWin: 0.9

Comment 7

16 years ago
Can you reproduce this in a recent build ( or even 0.9.9 )?

I think the 'Find in page' was fixed sometime ago.
If it was caused by the same thing maybe it is fixed ...
wfm, as nobody can reproduce it. reopen if you can.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.