Open Bug 1266103 Opened 4 years ago Updated 4 years ago

Unable to run some reftests using |mach reftest|

Categories

(Testing :: Reftest, defect)

48 Branch
defect
Not set

Tracking

(firefox48 affected)

Tracking Status
firefox48 --- affected

People

(Reporter: kats, Unassigned)

Details

I want to run the reftest at [1] locally. I tried the following:

./mach reftest "dom/canvas/test/reftest/webgl-capturestream-test.html?preserve"
./mach reftest "dom/canvas/test/reftest/webgl-capturestream-test.html"

Neither of these worked, they both reported "EXCEPTION: No tests to run". I suspect that in the former case the "?" part of the URL is getting stripped out and so it doesn't match anything in the reftest.list file. The latter also doesn't match anything in the reftest.list file. Normally running a reftest on a file which doesn't have extra URL goop works fine, so I can't think of any other reason this would fail.

Note also that if I run the entire folder:

./mach reftest "dom/canvas/test/reftest/"

then all the tests in that folder, including the one above, run just fine.

[1] http://mxr.mozilla.org/mozilla-central/source/dom/canvas/test/reftest/reftest.list?rev=3bcd4e72fab8#23
For now my workaround is to remove the "?preserve" from the filename in the reftest.list file, and to hard-code it inside the bits of the test that use it.
You need to log in before you can comment on or make changes to this bug.