Can't print on Windows 10 using Firefox 45

RESOLVED INVALID

Status

()

Core
Printing: Output
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: John Schneider, Unassigned)

Tracking

45 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

Select File -> Print, or Ctrl-P.  


Actual results:

It prepares the document, presents me with the printer selection window, then after selecting the printer, I see the percentage completion window.  Everything looks normal, but nothing ever prints.  I even tried going to Print Preview, which looks normal, but when I hit the Print button, it behaves exactly the same.

The strangest part of this (and this is the same behavior as I'm seeing in 45.0) is that once its finished with all the popups and it should be printing, I get the printer icon in my system tray.  When I hover over it, it says "0 document(s) pending for John".  After about a minute or two, that icon goes away.


Expected results:

Document should have printed.

This is on Windows 10 Pro x64.  Everything works fine under Windows 7 Ultimate x64.

Also having the exact same issue with Thunderbird 45.0.

Been through all the usual troubleshooting steps as seen in the following 2 threads:
https://support.mozilla.org/questions/1118591
http://forums.mozillazine.org/viewtopic.php?f=39&t=3000383
(Reporter)

Comment 1

2 years ago
Printing works fine with all other applications and browsers.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 2

2 years ago
Did you test with a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Did you test with a virtual printer?
Component: Untriaged → Printing: Output
Flags: needinfo?(John)
Product: Firefox → Core

Comment 3

2 years ago
Note: A "virtual printer" is something like printing to FreePDF, Foxit Reader PDF Printer, Microsoft XPS Document Writer, etc. (No everyone has one of those installed.)

For a fresh profile, start "firefox -p".
(Reporter)

Comment 4

2 years ago
Yes, I tested print-to-PDF and tried a new profile.  When printing to PDF, I get prompted for the output file name and location, but the PDF is never created.

Per the troubleshooting steps I tried, and were suggested to me in the thread at http://forums.mozillazine.org/viewtopic.php?f=39&t=3000383, which was originally regarding Thunderbird 45.0, the exact same issues are in Firefox 45.0.2:

I get the same error in Safe Mode.

Created a new profile, same error.

Print preview works fine.

Uninstalled Firefox, deleted the install folder, did clean install.

Updated the firmware and driver for my HP OfficeJet Pro 8615.

Printing works fine for all other apps and browsers (except Thunderbird 45.0 which gives the same error).

Tried deleting all the "print." entries in Prefs.js.

Given that this exact same issue exists in TB 45 and FF 45, it was suggested to me that I create a bug for Core::Printing:Output.

Please let me know if there is ANYTHING I can do to help.  I am more than willing to test dailies or whatever else is needed.

Thank You
Flags: needinfo?(John)

Comment 5

2 years ago
If you downgrade to 44 or 43 (link: http://ftp.mozilla.org/pub/firefox/releases/), does it work? If yes, maybe there is a rare regression in Firefox triggered by your system.
(Reporter)

Comment 6

2 years ago
Tested 43.0.4 and 44.0.2 and both also give the "An Error Occurred While Printing" error under Windows 10 Pro x64.  I then booted to my old Windows 7 Ultimate x64 partition and all 3 releases (45.0.2, 43.0.4 and 44.0.2) work fine.
(Reporter)

Comment 7

2 years ago
Sorry, I neglected to mention that after doing all the troubleshooting in comment 4 above, I no longer receive the "An Error Occurred While Printing" error.  However, still, nothing prints and I get that printer icon in the system tray with no documents pending.

Comment 8

2 years ago
I guess there is no error message in the browser console after printing has failed?
(Reporter)

Comment 9

2 years ago
I have not used the console before.  Please tell me how to check this.

Comment 10

2 years ago
(John's Thunderbird issue began in https://support.mozilla.org/en-US/questions/1118591 )
(Reporter)

Comment 11

2 years ago
After extensive testing and research on this issue, it turns out to be a problem with certain HP printers and Windows 10, so its not a Firefox/Thunderbird issue.

Sorry for the false alarm.

Comment 12

2 years ago
John, thanks for the update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 13

a year ago
I would like to have this bug re-opened. Now against Firefox 47.

Whenever I try to print something on Windows 10 using the Foxit PDF driver Firefox simply hangs with a small window with a status message about preparing the print job.

When using the native Windows 10 PDF driver the page prints OK.

Comment 14

a year ago
And that's a Firefox problem and not a Foxit problem?

Comment 15

a year ago
That's what I would like to figure out.

So far the finger points towards Firefox as it doesn't even log a single line in the console. Just locks up and has to be killed and restarted.
Other programs have no problem printing with the Foxit PDF driver.
(In reply to johnds@cbs.dtu.dk from comment #13)
> I would like to have this bug re-opened. Now against Firefox 47.
> 
> Whenever I try to print something on Windows 10 using the Foxit PDF driver
> Firefox simply hangs with a small window with a status message about
> preparing the print job.
> 
> When using the native Windows 10 PDF driver the page prints OK.

Hi John, thanks for reporting the issue.

Is it possible you might be hitting:
https://support.mozilla.org/en-US/kb/pages-appear-tiny-when-i-print-or-print-preview-firefox
Flags: needinfo?(john)

Comment 17

a year ago
Hi Bob,

Thanks for the pointer.
It didn't work with the -1, but I noticed that Firefox had changed the -1s with the metric paper sizes (height=297 and width=210) after printing with the Foxit PDF driver. But it was only changed for the Foxit PDF driver that I used.

Changing ALL defined printers to use these values made Firefox able to print using the Foxit PDF driver.



Best
John
Flags: needinfo?(john)
(In reply to johnds@cbs.dtu.dk from comment #17)

> Changing ALL defined printers to use these values made Firefox able to print
> using the Foxit PDF driver.

Glad it helped.
I seem to remember someone else saying that they had to change prefs for the other printers as well.
This doesn't make much sense to me, but if you see it again or can reproduce, please file another bug and CC me, thanks.

Comment 19

a year ago
I tried to reproduce and failed (of course).
With all other printers set to -1 I was still able to print with Foxit PDF driver.

Before that I just set the Foxit PDF driver to 11x9 and it failed. This makes me think that Firefox is actually interpreting the config paper sizes in millimeters and not inches as one might think. Thus 11x9 would render a very small paper size that the driver cannot handle.
Setting the width and height to -1 seems to cause Firefox to retrieve the paper size from the printer driver and update the config accordingly.

This is now solved for me.
(In reply to johnds@cbs.dtu.dk from comment #19)
> I tried to reproduce and failed (of course).

OK, thanks for trying.

> Before that I just set the Foxit PDF driver to 11x9 and it failed. This
> makes me think that Firefox is actually interpreting the config paper sizes
> in millimeters and not inches as one might think. Thus 11x9 would render a
> very small paper size that the driver cannot handle.

Yes, this is the problem. The old code sometimes left the prefs in an inconsistent state where the height and width were 11 and 8.5 (which is the inches measurement for the Letter paper type), but the print_paper_size_unit had been changed to 1 (millimetres).

Because of other "bugs" in the way we read back the prefs this didn't matter, but when I "fixed" the bugs to read the prefs correctly I tripped over this issue.

Unfortunately it also depends on what Print Drivers you are testing with, because all of mine rejected the small page size anyway, so I didn't see the issue.
You need to log in before you can comment on or make changes to this bug.