Closed Bug 1266142 Opened 4 years ago Closed 3 years ago

Radio button labels aren't vertically aligned with the circle on the devtools settings/options pane

Categories

(DevTools :: General, defect, P3)

48 Branch
All
Unspecified
defect

Tracking

(firefox48 wontfix, firefox49 verified, firefox50 verified)

VERIFIED FIXED
Firefox 50
Tracking Status
firefox48 --- wontfix
firefox49 --- verified
firefox50 --- verified

People

(Reporter: MattN, Assigned: Towkir)

References

Details

(Keywords: polish, regression, Whiteboard: [btpp-backlog])

Attachments

(5 files)

Checkbox labels seem more vertically aligned than the radio buttons.
Priority: -- → P3
Whiteboard: [btpp-backlog]
Hi, 
I was about to file another bug about it, luckily found it.
I have already fixed this,
See my attached screenshot left part is buggy, and right side is the fixed one, 
I will submit the patch soon.
Thanks
Here is the patch
Attachment #8766506 - Flags: review?(poirot.alex)
Taking this on me
Assignee: nobody → 3ugzilla
Attached image align.png
Here is what I get on Linux/Ubuntu.
Does your patch depend on some other changes?
Are you based against recent fx-team or mozilla-central checkout?
(In reply to Alexandre Poirot [:ochameau] from comment #5)

> Does your patch depend on some other changes?
I don't think so, I cleared all other changes, 
> Are you based against recent fx-team or mozilla-central checkout?
I was on mozilla-central

I think the css value should be 
	align-items: center;

You can try at your end with this value, then I can edit and submit a new patch.
thanks
Same result with align-items: center :/
Wait a sec. I do have some patchs on my queue. Let me try without them.
I have just tried it on another (fresh) PC before comment 6. this should have been the solution.
Dunno what's happening at yours
Comment on attachment 8766506 [details] [diff] [review]
fixed_label_vertical_alignment.patch

Review of attachment 8766506 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, I had one local patch messing up with this.
It looks good, thanks for this polish!
Attachment #8766506 - Flags: review?(poirot.alex) → review+
As you have approved, I think it is time :)
Status: NEW → ASSIGNED
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/69e91ad4fb9f
Fixed radio button labels vertical alignment in devtools settings/options pane. r=ochameau
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/69e91ad4fb9f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
QA Whiteboard: [good first verify]
Ummm.....
Looks like this issue is existing in the browser toolbox too. Where do I find the code for that please ?
Should it be in this bug or a new one should be filed ?
Sorry for the previous comment 14. I had some issues with browser updates. 
----------------------------------------
This is fixed on latest nightly
----------------------------------------
Version 	50.0a1
Build ID 	20160715063552
Update Channel 	nightly
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
OS 	Linux 4.2.0-41-generic
This is regression from bug 1246514. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=5b3f81a3277026268277c0ba4fe4815de7751228&tochange=5c5cf183a60890e651380e00533ce10d60375ffb

I can't completely verify this on:   Win7_64, Nightly 50, 32bit, ID 20160702030219   (2016-07-02)
because text labels aren't aligned the same way on checkboxes and radio buttons.
See attached "screenshot 4" for explanation.
Blocks: 1246514
Keywords: regression
Version: Trunk → 48 Branch
Too late for 48, please submit an uplift to 49.
I have reproduced this bug with Nightly 48.0a1 (2016-04-20) on Ubuntu 14.04, 64 bit!
The bug's fix is now verified on latest Nightly 51.0a1

Nightly 51.0a1:
Build ID 	20160804030441
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
I have successfully reproduce this bug on firefox nightly 48.0a1 (2016-04-20)
with windows 7 (32 bit)
Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0

I found this fix on latest nightly 51.0a1 (2016-08-02)

Mozilla/5.0 (Windows NT 6.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID : 20160802030437

[bugday-20160803]
Hi :Towkir,
Since this bug is a regression and also affects 49, do you consider to uplift this for 49 beta?
Flags: needinfo?(3ugzilla)
Comment on attachment 8766506 [details] [diff] [review]
fixed_label_vertical_alignment.patch

As this is a small UI change, I would say "Yes"

Approval Request Comment
[Feature/regressing bug #]: 1246514
[User impact if declined]: No major impact, small UI modification just with a css change.
[Describe test coverage new/current, TreeHerder]: No new automated test, manually tested and landed in nightly for one month without regression.
[Risks and why]: There is no risks actually
[String/UUID change made/needed]:
Flags: needinfo?(3ugzilla)
Attachment #8766506 - Flags: approval-mozilla-aurora?
Hi :Towkir,
The patch is already in 50 aurora. You should uplift this to 49 beta.
Flags: needinfo?(3ugzilla)
Comment on attachment 8766506 [details] [diff] [review]
fixed_label_vertical_alignment.patch

Oops, sorry about that.
Requesting approval for 49 beta:

Approval Request Comment
[Feature/regressing bug #]: 1246514
[User impact if declined]: No major impact, small UI modification just with a css change.
[Describe test coverage new/current, TreeHerder]: No new automated test, manually tested and landed in nightly for one month without regression.
[Risks and why]: There is no risks actually
[String/UUID change made/needed]: None
Flags: needinfo?(3ugzilla)
Attachment #8766506 - Flags: approval-mozilla-aurora? → approval-mozilla-beta?
Comment on attachment 8766506 [details] [diff] [review]
fixed_label_vertical_alignment.patch

Review of attachment 8766506 [details] [diff] [review]:
-----------------------------------------------------------------

This patch fixes a UI regression. Take it in 49 beta. Should be in 49 beta 5.
Attachment #8766506 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1267788
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.