Closed Bug 1266183 Opened 4 years ago Closed 2 months ago

Submissions with varying numbers of subtests end up in different graphs

Categories

(Tree Management :: Perfherder, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: chmanchester, Unassigned)

References

Details

Last week I landed a change to record "configure" as a tier so we can track progress in perfherder. I think this is causing an issue in the UI: https://treeherder.mozilla.org/perf.html#/graphs?series=%5Bmozilla-inbound,39ba40a05c72b137e5b189b75949f64e37c9d416,1%5D&series=%5Bmozilla-inbound,8555b3405a4d6fca6716db38c31dc94d1c4f8fe1,1%5D

I seem to have split the data into two graphs, one for builds that run configure, and one for those that don't.
This is currently "by design", since summaries with different subtests hash to a different summary series (I guess the theory is that summaries with different subtests are not equivalent). However, I am reconsidering this (along with the whole idea of a "series signature"), so let's leave this open for now. This has confused lots of people already, almost certainly moreso than the straightforward alternative of not incorporating subtest information into the hash (or not using a hash at all, for that matter).
Duplicate of this bug: 1279292
Priority: -- → P5
Priority: P5 → P3

For some time now, we've disabled most of the signature's hash mechanics, so I don't think this ticket is relevant anymore.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.