UI elements become larger when moused over on retina displays/monitor on Mac OS X or windows moved between lowdpi/hidpi

RESOLVED FIXED in Thunderbird 45.0

Status

Thunderbird
OS Integration
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Tim Brier, Unassigned)

Tracking

({multi-monitors, regression, regressionwindow-wanted})

45 Branch
Thunderbird 45.0
Unspecified
Mac OS X
multi-monitors, regression, regressionwindow-wanted

Thunderbird Tracking Flags

(thunderbird_esr38 unaffected, thunderbird_esr4546+ fixed)

Details

(Whiteboard: [regression:TB45?][relnote][workaround:resize window])

Attachments

(5 attachments)

(Reporter)

Description

2 years ago
Created attachment 8743755 [details]
inbox_screen.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Steps to reproduce:

Open Thunderbird on a retina display.
Mouse over certain UI elements


Actual results:

The UI element becomes larger and moves position. After resizing the window things go back to normal


Expected results:

The UI element highlights but remains the same size and in the same position
(Reporter)

Updated

2 years ago
OS: Unspecified → Mac OS X
(Reporter)

Comment 1

2 years ago
Created attachment 8743756 [details]
compose_screen.png
I have no retina Mac and can't test this. A shot into the dark, can you try in Preferences > Advanced > General to toggle the 'Use hardware acceleration when available'. And what was the initial state of this pref before toggle?

Do you use Firefox? If yes, do you see the same with it?
(Reporter)

Comment 3

2 years ago
The initial state of that toggle was disabled, the issue occurs both when it is enabled and disabled. I'll download firefox now to test that.
Do you have only one retina screen or a mix of a retina and a normal screen?
(Reporter)

Comment 5

2 years ago
I can't reproduce the issue on Firefox 45.0.2.

I've also discovered that it only occurs if you open thunderbird on a non retina display initially then move it to a retina display. If you open it on a retina display then move it to a non retina display the entire UI shrinks down into the top left corner. Image attached.
(Reporter)

Comment 6

2 years ago
Created attachment 8743762 [details]
retina2nonretina_compose_screen.png
Could you try to restart TB in safe mode (Help > Restart with Add-ons disabled...) to check it's not a custom setting making this issue?
(Reporter)

Comment 8

2 years ago
If I restart in safe mode the issue still occurs.
Mike, do you maybe know what could be the difference between TB and FX (both v45) that FX rescales correctly and TB not? Does TB missing something FX has?
Flags: needinfo?(mconley)

Comment 10

2 years ago
Created attachment 8744219 [details]
Capture d’écran 2016-04-22.png

Hello I have the same problem ! Since the Thunderbird update 45 days (on MacBookPro). The interface is broken when you click on button "write". See Full attachments(French localization).

Antoine
Duplicate of this bug: 1267458
Is this reproducible with Hardware Acceleration disabled? (Preferences > Advanced > "Use hardware acceleration when available")
Flags: needinfo?(mconley) → needinfo?(t.brier93)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #12)
> Is this reproducible with Hardware Acceleration disabled? (Preferences >
> Advanced > "Use hardware acceleration when available")

See comment 3: it was disabled and also enabling didn't help.
Ah, sorry - should have read the bug more closely.

Can I see the Graphics sections from about:support (Help > Troubleshooting Information) for anybody experiencing this?
I can reproduce this as soon as I plug or unplug my external monitor and Thunderbird automatically gets moved to a screen running a different resolution.

  Graphics

      Vendor ID: 0x1002
      Device ID: 0x6821
      WebGL Renderer: ATI Technologies Inc. -- AMD Radeon R9 M370X OpenGL Engine -- 2.1 ATI-1.42.6
      GPU Accelerated Windows: 0

      AzureCanvasBackend: skia
      AzureSkiaAccelerated: 1
      AzureFallbackCanvasBackend: none
      AzureContentBackend: quartz
Flags: needinfo?(t.brier93) → needinfo?(mconley)
Needinfo'ing mstange to see if he has insight. This sounds similar to a class of bugs we were seeing for a while, but then they went away (not sure if/how they got fixed).
Flags: needinfo?(mconley) → needinfo?(mstange)
Might be related to bug 1255638.
See Also: → bug 1255638

Comment 19

2 years ago
bug 1249707 is the oldest of approximately 10 reported Mac screen issues in version 45 http://mzl.la/24mYQik  But this bug has the most info, so declaring this bug as canonical for Thunderbird. Please do not move this bug to Core.

I have not inspectede http://mzl.la/24mZigo to determine relevant Core bug(s) (nor even if this is an optimal bug query).  Could someone check thsese?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
Whiteboard: [regression:TB45?][relnote]

Comment 20

2 years ago
http://mzl.la/24n15lO is better Core query for possible relevant bugs

Comment 21

2 years ago
I have a Retina Mac, but no external monitor, so I can't reproduce. Just guessing, I know that some related issues were fixed for Firefox for ipc/e10s, could it be, that we are seeing this in Thunderbird, because TB isn't using ipc/e10s?

Updated

2 years ago
Duplicate of this bug: 1268709

Updated

2 years ago
Duplicate of this bug: 1268964

Updated

2 years ago
Duplicate of this bug: 1249707

Updated

2 years ago
Duplicate of this bug: 1257553

Updated

2 years ago
Duplicate of this bug: 1265699

Updated

2 years ago
Duplicate of this bug: 1268566

Updated

2 years ago
Duplicate of this bug: 1268531

Comment 29

2 years ago
CC jfkthame who is familiar with the many core bugs of this type

clokep says he's seen this for a very long time. bug 1249707 is the oldest thunderbird bug, reported 2016-02-19 and presumably 45.0 beta which came out February 10, 2016. This _should_ mean that Firefox 45 beta at that time had the same bug but no has stated so in their bug reports.

Note workaround: resize window.
status-thunderbird_esr45: --- → affected
tracking-thunderbird_esr45: --- → ?
Flags: needinfo?(jfkthame)
Keywords: multi-monitors
Summary: UI elements become larger when moused over on retina displays → UI elements become larger when moused over on retina displays/monitor on Mac OS X or windows moved between lowdpi/hidpi
Whiteboard: [regression:TB45?][relnote] → [regression:TB45?][relnote][workaround:resize window]
Maybe it was caused by bug 1187322, which was uplifted to 45?
Flags: needinfo?(mstange)

Comment 31

2 years ago
(In reply to Markus Stange [:mstange] from comment #30)
> Maybe it was caused by bug 1187322, which was uplifted to 45?

Than somebody who is affected should test with Thunderbird 44.

Comment 32

2 years ago
(In reply to Markus Stange [:mstange] from comment #30)
> Maybe it was caused by bug 1187322, which was uplifted to 45?

Then we need regression bug 1248675?  which hasn't been uplifted to 45esr
As the reporter of bug 1249707 I'm 100% positive that this bug only showed up with 45 and did not existed in 44 (as I have been using the same multi monitor setup for a long time).
Firefox might actually have had a similar issue, where the DOM space would get rendered substantially smaller when Firefox got move from the retina screen to the external non-retina screen. I had that problem for quite some time. But in Firefox this was not 100% reproducible (which it is for me with Thunderbird), and in Firefox a simple reload of the page fixed the problem. I have no data to back it up, but I'm pretty sure I have not seen the issue in the latest releases (47, 48,...) any more.

Updated

2 years ago
Duplicate of this bug: 1269329
The description in comment 33 matches my experiences too. In Firefox you just refresh the page and it works, but you can't do that in Thunderbird. I'm unsure of specific versions.
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #32)
> (In reply to Markus Stange [:mstange] from comment #30)
> > Maybe it was caused by bug 1187322, which was uplifted to 45?
> 
> Then we need regression bug 1248675?  which hasn't been uplifted to 45esr

It seems so.

Updated

2 years ago
See Also: → bug 1248675

Updated

2 years ago
Duplicate of this bug: 1269507
(In reply to Markus Stange [:mstange] from comment #36)
> (In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment
> #32)
> > (In reply to Markus Stange [:mstange] from comment #30)
> > > Maybe it was caused by bug 1187322, which was uplifted to 45?
> > 
> > Then we need regression bug 1248675?  which hasn't been uplifted to 45esr
> 
> It seems so.

I agree bug 1248675 looks very likely to be what's needed here. I see has been marked status-thunderbird_esr45:fixed. So can someone confirm this problem is now fixed for TB? It's not clear to me where the patch needs to have landed to resolve this.
Flags: needinfo?(jfkthame)

Comment 39

2 years ago
(In reply to Jonathan Kew (:jfkthame) from comment #38) 
> I agree bug 1248675 looks very likely to be what's needed here. I see has
> been marked status-thunderbird_esr45:fixed. So can someone confirm this
> problem is now fixed for TB? It's not clear to me where the patch needs to
> have landed to resolve this.

Kent didn't indicate to me the patch landed on THUNDERBIRD_45_VERBRANCH and I can't find it, so I believe flag=fixed at bug 1248675 comment 21 is in error and should "affected". And Kent, the patch has been on Firefox (non-esr) beta for a month so I'm comfortable taking the patch for TB 45.1 release without going through TB beta.
Flags: needinfo?(rkent)

Comment 40

2 years ago
OK I fixed in in-error "fixed" on bug 1248675
Flags: needinfo?(rkent)

Comment 41

2 years ago
Bug 1248675 has now been pushed to the TB 45 branch of m-esr45, so it is possible that fixed this bug.
(In reply to Kent James (:rkent) from comment #41)
> Bug 1248675 has now been pushed to the TB 45 branch of m-esr45, so it is
> possible that fixed this bug.

How/Where can I get a new build from that branch to update(?)/replace my current 45 to test/verify this?

Comment 43

2 years ago
Nils: The earlier push on 2016-05-05 had to be backed out because of a build failure. This was repushed on 2016-05-07 (about 15 minutes ago). Any comm-esr45 nightly builds created after now should have the fix. I would appreciate testing of this, so I'll try to post a link after a build completes.

Comment 44

2 years ago
Here is the nightly build that includes this fix:

http://archive.mozilla.org/pub/thunderbird/nightly/2016/05/2016-05-08-03-02-00-comm-esr45/thunderbird-45.1.0.en-US.mac.dmg

I would appreciate if anyone who see this bug try that build, and comment on whether it fixes the issue. It is clear yet if this will be included in 45.1.0 or a later release yet, and testing reports could help decide.

Comment 45

2 years ago
(In reply to Kent James (:rkent) from comment #44)
> Here is the nightly build that includes this fix:
> 
> http://archive.mozilla.org/pub/thunderbird/nightly/2016/05/2016-05-08-03-02-
> 00-comm-esr45/thunderbird-45.1.0.en-US.mac.dmg
> 
> I would appreciate if anyone who see this bug try that build, and comment on
> whether it fixes the issue. It is clear yet if this will be included in
> 45.1.0 or a later release yet, and testing reports could help decide.
Flags: needinfo?(t.brier93)
Flags: needinfo?(drno)

Comment 46

2 years ago
I couldn't reproduce the problems i reported in https://bugzilla.mozilla.org/show_bug.cgi?id=1269329 . I only noticed that the text is being rendered quite blurry when moving between two screens with different resolutions. As soon as I stop moving the window the text seems to get re-rendered and looks fine again. I believe this is not a problem and probably necessary?

This bug seems to be fixed for me.
(Reporter)

Comment 47

2 years ago
I can't reproduce the bug in the nightly from comment 44
(Reporter)

Updated

2 years ago
Flags: needinfo?(t.brier93)

Comment 48

2 years ago
Likewise - I cannot reproduce the problems I had reported in https://bugzilla.mozilla.org/show_bug.cgi?id=1202056.

(In reply to Tim Brier from comment #47)
> I can't reproduce the bug in the nightly from comment 44
Verified that the early bird from comment #44 fixes the rendering issue.
Flags: needinfo?(drno)

Comment 50

2 years ago
The fix in Earlybird 45.1.0 corrects most of the issues, but not entirely.  For example, when composing a message and inserting a link, the popup to specify the link parameters is incorrectly sized when viewed on a secondary (external) monitor.  It is correctly sized when viewed on the primary (laptop) monitor.

When initially displayed on the primary monitor and then dragged to the secondary, the popup becomes incorrectly sized.  However, when initially displayed on the secondary and then dragged to the primary, the popup does *not* resize to the correct display.  I'll attach a screen capture of how it looks on the secondary monitor.

Comment 51

2 years ago
Created attachment 8750509 [details]
Popup for link sized incorrectly on secondary monitor

Comment 52

2 years ago
Thanks for all of the help. We will be including this patch in 45.1.0 which we are building now.

If you have additional issues, since these are all in core code shared with Firefox, it would be best if you tried to reproduce under current versions of Firefox, since that is who has the resources to fix this class of bugs. Unfortunately there will be no version of Firefox that simply includes this patch, other than much later versions that have lots of other changes in the affected graphics code. So we will probably end up having to live with any remaining problems until the next major release of Thunderbird, version 52 in January 2017.
Duplicate of this bug: 1271920

Comment 54

2 years ago
I just wanted to join in on this bug.  I am experiencing the exact same issues.  I see that it may be fixed in 45.1 - But just wanted to join in with a 'me too' in case extra testing is needed.
I was able to test the current beta build (build 3) and this issue seemed fixed there.

Fixed by https://hg.mozilla.org/releases/mozilla-esr45/rev/18fab019eb66 (see bug 1248675, comment 22).

I have still seen some issues with drop downs (comment 50), but I also see those in Firefox 47 beta, so I think this is good to close.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 45.0

Updated

2 years ago
status-thunderbird_esr38: --- → unaffected
status-thunderbird_esr45: affected → fixed
tracking-thunderbird_esr45: ? → 46+

Comment 56

2 years ago
The issue is not completely fixed in 45.1.0 - the sizing issue described in comment 50 and screenshotted in comment 51 still exists (and did not exist prior to 45.0).  The issue seems to affect all the toolbar items that pop up a small options window - e.g. adding a link or an image to an email, selecting a colour.  Should I create a new issue for this bug, or continue it in this one?
Glenn, please file a new bug. Please can you check this before filing if you can reproduce with Firefox? When it not happens on actual Firefox, could you test it with FX 45? When FX 45 is affected and later not then it's fixed meanwhile and where is a bug which needs uplift. When it also happens with actual FX then best is to file against Firefox.
You need to log in before you can comment on or make changes to this bug.