Closed Bug 126637 Opened 18 years ago Closed 18 years ago

PR_USPacificTimeParameters uses "std" as internal variable name

Categories

(NSPR :: NSPR, defect, P2, trivial)

x86
Windows 2000
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sjulier, Assigned: wtc)

References

()

Details

Attachments

(1 file)

CVS snapshot from 20th February, 2002 (09:22 EST) compiling using MSVC (version
6.0) with stlport 4.0.

In prtime.c, the function PR_USPacificTimeParameters uses "std" as an internal
variable name. When I try to compile with the stlport include directory in my
INCLUDE environment variable, I get a number of compilation errors of the form:

prtime.c(792) : error C2143: syntax error : missing ';' before '.'

These can be eliminated by renaming the internal variable to something other
than "std".
Thanks for the bug report.  Just curious -- do you know
why 'std' is causing problems?  What is 'std' in stlport?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Although 'std' is the C++ namespace for standard C library
functions, a C file should be able to use 'std' as an identifier.
So this is really a bug in the stlport 4.0 header files.
Patch checked into the tip of NSPR.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → 4.2
After checking the STLPORT 4.0 headers, I have found that this particular
problem is caused by a bug in STLPORT.

To ensure that namespaces work correctly, STLPORT includes its own version of
"stdio.h" and other standard C header files. As part of the configuration
process, std is unconditionally #undef'd in a related header file.
Could you submit a bug report to the STLPORT maintainers
about this problem?  Thanks.
You need to log in before you can comment on or make changes to this bug.