"No writable calendars are configured for invitations, please check the calendar properties"

RESOLVED WORKSFORME

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED WORKSFORME
2 years ago
9 months ago

People

(Reporter: Martijn, Unassigned)

Tracking

Lightning 4.7
x86_64
Windows 10

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

I received an invitation.


Actual results:

The invitation has an extra header that says "No writable calendars are configured for invitations, please check the calendar properties".

This is wrong, because I have one calendar that is writable, among a couple others that aren't.


Expected results:

In stead of that message, add button to accept (add to calendar) or reject the invitation.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

2 years ago
what version calendar?
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 45 Branch → unspecified
(Reporter)

Comment 2

2 years ago
It auto-updates, so it should be the latest version, which is 4.7.

Comment 3

2 years ago
Being writable is only one requirement for invitations. 

Next requirement is that the used calendar provider actually supports invitations. Are you using local or remote calendars? What type of remote calendar?

Next requirement is that an email account is associated with the calendar. You can choose the account during calendar creation or later from the calendars properties dialog.

Are those requirements fulfilled too?
Component: General → E-mail based Scheduling (iTIP/iMIP)
Flags: needinfo?(martijn)
Version: unspecified → Lightning 4.7
(Reporter)

Comment 4

2 years ago
What does it mean to support invitations? Isn't it simply a matter of popping a calendar entry into the calendar? You know, just like a user would do manually?

Anyway, it's a Google calendar, which does support invitations (although not sure what that means). This used to work in an earlier version of TB and/or Calendar, but which exact version I don't recall.
Flags: needinfo?(martijn)

Comment 5

2 years ago
How do you access your Google Calendar? Using the build-in CalDAV, the separate provider for Google extension or just the ICS? The later would be expected to not work because it's read only from Google's end.Also, is this your primary Google calendar?
(Reporter)

Comment 6

2 years ago
I'm using the provider for Google extension.

And yes, it's my primary Google calendar. I do have other calendars from coworkers, which aren't writable for me, so if we forget those, I have a single writable calendar.

Comment 7

2 years ago
Maybe calendars created using the Provider for Google Calendar extension still not support invitations yet. 

Could you create a new local calendar for testing, associated an email account with it and test if you can accept the invitation into it?

Do you get any error messages in Tools > Error Console when viewing the email with the invitation?
Flags: needinfo?(martijn)
(Reporter)

Comment 8

2 years ago
I found that in the calendar properties, I had set the "e-mail" field to another e-mail account than the one invitations where coming in on.

This leads me to think, what if I use a single (remote?) calendar for multiple e-mail accounts? That will never work. So why is a calendar attached (and so hard to spot as well) to a single e-mail account? That doesn't make any sense to me. Iow, when an invitation comes in, and I do have multiple writable calendars, let me pick. If I have a single calendar, just use it. What does it matter on which e-mail account an invitation is received??

No errors in the error console btw.
I have this problem too and I have seen it reported a lot across the internet for people using "Provider for Google Calendar"

I have had it on multiple versions of Thunderbird and Lightning on Linux (and a small stint on MacOS).

See:
https://support.mozilla.org/en-US/questions/1092628
https://support.mozilla.org/en-US/questions/1108836

The recommended solution appears to be "Use CalDAV" which is a shame because you have to add every calendar manually and finding the CalDAV URIs can be very difficult and is generally done by finding blog posts across the internet until you find one that works.
The Provider for Google Calendar only allows invitations to be placed in the primary calendar, as Google also has this restriction.

As for supporting two email addresses on one calendar, I am pretty sure we have a bug for this open. I'd like to close this one as the initial problem was slightly different and the workaround was found, but be assured I am aware of it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(martijn)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.