Multiple "The text you entered was not found" dialogs

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: 1212mozilla, Assigned: jag-mozilla)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Press ^f and search for a word that occurs multiple times on a page.  
On http://java.sun.com/j2se/1.3/docs/api/allclasses-frame.html a good word to
search for is "basic".  Find the first occurance and then close the find dialog.
Search for all occurances of "basic" by holding down the search again key (^g)
until you have reached the last occurance.  At this point let up on the key and
watch mozilla pop up many many "The text you entered was not found" dialogs.  I
just got 29 dialogs which I had to close.  I should only get one.  To make this
worse, mozilla becomes unresponsive as it generates all these dialogs (which may
take a minute or more.)

Comment 1

17 years ago
-> pmac QA contact
QA Contact: sairuh → pmac

Comment 2

17 years ago
Stephen, what build ID did you use? I couldn't reproduce your problem.
It seemed I had different problem.
I was holding the (^g) to search again until the last occurance, 
first, it took a minutes or more to pop up "1" dialog only "The text you entered 
was not found". Then I tied the second or third time again, it hung there without
popping up a dialog at all.
(linux: netscape commercial build: 2002-02-19-06-trunk).
 

Comment 3

17 years ago
nominating nsbeta1 
Keywords: hang, nsbeta1
(Reporter)

Comment 4

17 years ago
Once a dialog has appeared, pressing ^g has no effect. (No more dialog boxes
appear.)  However when you press ^g multiple times (or hold it down) after you
have found the last occurance but before the dialog appears, mozilla will
generate additional dialog boxes which it displays all in the same place.
I'm using build 2002021411 and will try a new one. 
(Reporter)

Comment 5

17 years ago
I just downloaded and tested build 2002022008 (linux) with the same results.  I
also tried moving the dialog boxes around just to make sure that it was indeed
many separated dialog boxes and not just one on which the ok button was somehow
broken.  I discovered that the dialog boxes generated are somehow model to each
other.  You must close them in the reverse order they popped up.

It also appears to not matter how many times a word appears on the page, but how
close you are to the bottom when you start searching.  I can cause this problem
by searching for "funkychicken" (which is found nowhere in the document) if
"AbstractAction" is highlighted, I can not cause this problem by searching for
"funkychicken" if "_Remote_Stub" is highlighted.

New instructions for duplicating:
highlight the "All Classes" at the top of the page.
^f seach for "AbstractAction"
close all dialogs.
press ^g twice in quick succession.
you will get two dialogs.

Comment 6

17 years ago
->bryner
Assignee: trudelle → bryner

Comment 7

17 years ago
Stephen, thanks for providing more details. I could easily reproduce this with 
your comment #5. Yes, there're two dialogs pop up. It also happens on windows 98
and Mac os 9.2 as well. So change to OS: All.
OS: Linux → All
Hardware: PC → All

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Product: Core → Mozilla Application Suite
Assignee: bryner → jag
QA Contact: pmac

Comment 9

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.