Dragging tabs is a bit harder than it used to be

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(e10s+, firefox45 unaffected, firefox46 unaffected, firefox47 unaffected, firefox48 unaffected, firefox49- affected)

Details

(Reporter)

Description

2 years ago
I'm running Nightly on Ubuntu 14.04 LTS (64-bit).

Dragging tabs only works if you drag the tab within the area where the tabs appear. If you drag your mouse a little down over the address bar then you won't be able to drag that tab anymore and have to start again.
(In reply to Armen Zambrano [:armenzg] - Engineering productivity from comment #0)
The summary says "used to be".

When did this behave differently?
Flags: needinfo?(armenzg)
(Reporter)

Comment 2

2 years ago
Oh I thought I remembered that I never had trouble with it.
Maybe using the trackpad instead of the mouse on Linux made me more clunky?

I thought that temporarily moving the mouse over to the address bar did not matter before.
I thought that what matters is where the last point is when you release the mouse click.
Flags: needinfo?(armenzg)
(In reply to Armen Zambrano [:armenzg] - Engineering productivity from comment #2)
> Oh I thought I remembered that I never had trouble with it.
> Maybe using the trackpad instead of the mouse on Linux made me more clunky?
> 
> I thought that temporarily moving the mouse over to the address bar did not
> matter before.
> I thought that what matters is where the last point is when you release the
> mouse click.

Well, maybe I misunderstand. When you:

1. start drag on tab
2. drag over location bar
3. move mouse back into tab strip
4. drop

Does the tab move? Because it does for me on OS X. It's possible this broke in gtk3? Can you try e.g. Firefox 45 release off https://www.mozilla.org/ (built with gtk2) ?
Flags: needinfo?(armenzg)
(Reporter)

Comment 4

2 years ago
It works of FF45.
Flags: needinfo?(armenzg)
status-firefox45: --- → unaffected
status-firefox46: --- → ?
status-firefox47: --- → ?
Keywords: qawanted, regression, regressionwindow-wanted

Comment 5

2 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Armen Zambrano [:armenzg] - Engineering productivity from
> comment #2)
> > Oh I thought I remembered that I never had trouble with it.
> > Maybe using the trackpad instead of the mouse on Linux made me more clunky?
> > 
> > I thought that temporarily moving the mouse over to the address bar did not
> > matter before.
> > I thought that what matters is where the last point is when you release the
> > mouse click.
> 
> Well, maybe I misunderstand. When you:
> 
> 1. start drag on tab
> 2. drag over location bar
> 3. move mouse back into tab strip
> 4. drop
> 
> Does the tab move? Because it does for me on OS X. It's possible this broke
> in gtk3? Can you try e.g. Firefox 45 release off https://www.mozilla.org/
> (built with gtk2) ?

regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=305f923c6f9c953518c9e8bcfb70bcae3c7f8af8&tochange=aa65acd9650aa99e5452dd7344ff06d387c6e3f9

regressed by:
aa65acd9650a	Neil Deakin — Bug 1256952, send a dragexit at remote process when leaving the remote frame, r=smaug
Blocks: 1256952
status-firefox46: ? → unaffected
status-firefox47: ? → affected
Keywords: regressionwindow-wanted
I could reproduce the issue only when e10s is enabled on Ubuntu 14.04. I could not reproduce the issue on other OSs like Windows 10 x64 bit and Mac OS X 10.10.

Removing the qawanted keyword, please set it back if any other investigation is needed.
tracking-e10s: --- → ?
Keywords: qawanted

Comment 7

2 years ago
Neil, wondering what your plans are with this one. It's a regression from bug 1256952 which is in 47.
Flags: needinfo?(enndeakin)
I backed out the regressing patch from Aurora. I will continue to investigate, but am waiting for karlt to see if he has any info here.
Flags: needinfo?(enndeakin)

Updated

2 years ago
Depends on: 1269282

Updated

2 years ago
Blocks: 1269282
No longer depends on: 1269282

Comment 9

2 years ago
Hey alice, can you confirm this is fixed?
Flags: needinfo?(alice0775)

Comment 10

2 years ago
I can confirm that the problem is no longer reproduced on Aurora[2] with e10s.

However, I can still reproduce the problem on Nightly[1] and Beta[3] with e10s.

Because, the offending patch is not backed out from Nightly49.0a1 and Beta47.0b2.

[1]
https://hg.mozilla.org/mozilla-central/rev/369a5ee3a2880a4a98df3a00bf3db8d8f36b181b
Mozilla/5.0 (X11; Linux i686; rv:49.0) Gecko/20100101 Firefox/49.0 ID:20160505030327

[2]
https://hg.mozilla.org/releases/mozilla-aurora/rev/b6738ca644382710da35245e0c2e01479befeb37
Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160505004017

[3]
https://hg.mozilla.org/releases/mozilla-beta/rev/6f82d30fe05e1412e744cb76af86f0c9ffe509d4
Mozilla/5.0 (X11; Linux i686; rv:47.0) Gecko/20100101 Firefox/47.0 ID:20160502152141
Flags: needinfo?(alice0775)

Comment 11

2 years ago
Thanks, there's a backout on beta too, should be in build 3 which comes out this weekend.
status-firefox47: affected → unaffected
status-firefox48: affected → unaffected
status-firefox49: --- → affected
tracking-e10s: ? → +
Tracking for 49 so we don't lose track of it.
tracking-firefox49: --- → +
ni on Armen or anyone else that can reproduce this issue - this should be fixed in B4 due to the backout according to Comment 11 - can we please test again and update the bug? Thanks!
Flags: needinfo?(armenzg)
(Reporter)

Comment 14

2 years ago
It seems that nightly is working for me.
Flags: needinfo?(armenzg) → needinfo?(mozillamarcia.knous)
No longer necessary to track for 49 based on Comment 14 and the fact that the patch was backed out.
tracking-firefox49: + → -
Flags: needinfo?(mozillamarcia.knous)

Updated

2 years ago
No longer blocks: 1269282
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
The regressing bug was backed out.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.