All users were logged out of Bugzilla on October 13th, 2018

Status

VERIFIED DUPLICATE of bug 120313
17 years ago
2 years ago

People

(Reporter: cote, Assigned: law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002010406

I upload a file to my webserver, go see it by http, and save it back, the layout
is lost.

Reproducible: Always
Steps to Reproduce:
1. Go to the url http://www.tzone.org/~gcote/gcote_cv.html
2. Save the file on your local disk 
3. Open the file you just save in your browser

Actual Results:  A file with no formatting

Expected Results:  Save as should give me the same file byte to byte, as the one
I upload on the server

I'll attach the two file to the bug after it's created.
(Reporter)

Comment 1

17 years ago
Created attachment 70518 [details]
before

The page I upload on my server
(Reporter)

Comment 2

17 years ago
Created attachment 70519 [details]
after

The file I save with saveas
Which file type did you select to save as in the filepicker?  It looks like you
chose text/plain....
(Reporter)

Comment 4

17 years ago
I didn't care and choose the default.  After looking back, the dialog open with
Text File selected by default.  If I choose back the web page only, it save the
file correctly.

Is it normal that html file are save as txt by default?

Is it normal the name of the file on the disk is .html, should it be .txt?

The default is whatever you chose the last time you used the dialog.  So if you
saved a page as text at some point it would stay that way until you undid it....

The fact that the extension is wrong is bug 120313, of which I'm marking this a
duplicate.

*** This bug has been marked as a duplicate of 120313 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.