Markup search autocomplete in inspector doesn't match names with a "-" or "_" character

RESOLVED DUPLICATE of bug 1220387

Status

P2
normal
RESOLVED DUPLICATE of bug 1220387
3 years ago
4 months ago

People

(Reporter: jsnajdr, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox48 affected)

Details

(Whiteboard: [btpp-fix-later])

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Create a document with element <div class="style-a style-b">
2. Open Inspector, type "style" into the "Search HTML" box
3. The search box shows autocomplete option for ".style-a" and ".style-b"
4. Type one more character: "-"

Expected results:
I still see the two autocomplete options, as "style-" still matches them.

Actual results:
Both autocomplete options disappear - the text no longer matches anything.

The logic in SelectorAutocompleter.showSuggestions seems to be broken. When we are in state States.TAG, matches for CLASSes and IDs are also shown (which is great), but only if the typed text matches a regexp for TAG (with [a-zA-Z]*), which is not so great.
Inspector bug triage. Filter on CLIMBING SHOES.

Could be related to Bug 1245365 (possible duplicate?)
Assigning same priority -> P2
Priority: -- → P2
See Also: → bug 1245365
Whiteboard: [btpp-fix-later]

Comment 2

3 years ago
Bug 1245365 is unrelated: that one is most likely a recent regression from bug 835896.

@ Jarda Snajdr (reporter): If there's anything different from bug 1220387, please reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1220387

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.